Telit GPS not covered by SixFab tutorial


I got the Telit LE910C1 LTE module because the Quectel was unavailable at the time of purchase.
Hopefully this can help someone else if they bump into the same issues.

The SixFab tutorial Read GNSS/GPS Data with Sixfab Shield/HAT is not applicable to the Telit module (it doesn’t understand the AT+QGPS=1 command)

I read the LE910CX AT command reference and came up with this procedure:

Install minicom and gpsd
sudo apt-get install gpsd gpsd-clients python-gps minicom

Open the AT serial port of the Telit module
minicom -D /dev/ttyUSB2 -b 115200

Send the following commands:

AT$GPSP=1 #power on GPS
AT$GPSNMUN=1,1,1,1,1,1,1 #enable stream of GPS sentences on dev/ttyUSB1
AT$GPSQOS=0,0,0,0,2,3,1 #set high accuracy QOS
AT$GPSSAV #save settings
AT$GPSR=1 #restart module

Stop gpsd.socket so that it doesn’t interfere with manual testing

sudo systemctl stop gpsd.socket
sudo systemctl disable gpsd.socket

Tie gpsd socket to ttyUSB1

sudo gpsd /dev/ttyUSB1 -F /var/run/gpsd.sock

Start gpsmon, and you should see - after some time - an output like the image attached.

if that works, then edit /etc/default/gpsd and add DEVICES="/dev/ttyUSB1"
Reenable the services

sudo systemctl enable gpsd.socket
sudo systemctl start gpsd.socket
sudo reboot

It took almost 5 minutes to get a position lock - not sure what’s going on there. Most GPS should get a lock in 30 seconds. And the refresh rate is 1Hz. Not sure if it can go higher to 5Hz or 10Hz like some higher-end GPS - couldn’t find info on that in the Telit user guide.


Hi @sylvain.goyette,

Thanks for sharing your experience.

We will be updating the tutorial to cover Telit soon.

Hello @ensar,

I am using the Telit LE910C1-EU LTE module and I followed @sylvain.goyette steps but I still cannot get any data after starting gpsmon
I even tried getting the GPS data using commands like: AT$GPSACP and AT$GPSNMUN=3,1,1,1,1,1,1 but it is giving me no output just blank.
Can you please help me out with this.

Why USB2? Nothing explains why different tutorials use different USB# commands. I thought my original setup used USB3…
if I open USB2, I am getting AT commands the just appear and get in the way of typing AT commands.

Returns a ERROR

Will the Telit GPS tutorial be done soon? @ensar

Hi @ljbdeshler ,

Yes, it will be added to this tutorial soon.

Please follow the updates. Thanks.

It could be due to the selected USB composition - it changes how the ttyUSBx ports behave.
Are you able to run AT#USBCFG? (including the question mark). default value should be 0 according to the spec.

I did get a 0 for at#usbcfg? I have had other people in the company who are more familiar with the pi and we cannot get any gps data out of the telit module. We can lock it up in minicom and the pi has to be reset so I am good at that :wink:

Sorry dude. That’s the extent of what i personally tried to get mine to work :slight_smile: Hope you figure it out.