QMI + Rogers (Ontario Provider) + requestSetupDataCall Error


Following the QMI guide with the 4G/LTE Cellular Modem Kit, everything installed with no errors. Unfortunately, the final command to connect to the internet gets stuck at ‘requestSetupDataCall’. I have attached the outputs for the recommended commands from the troubleshooting page, the response from running the ‘sudo ./quectel-CM -s <APN_NAME>’ command as well as the responses from the AT commands.
I have tried multiple possibilities for the Rogers APN(and potential username/passwords):
sudo ./quectel-CM -s internet.com (With and without username: wapuser1 and password: wap)
sudo ./quectel-CM -s ltemobile.apn

I have also confirmed with the provider that the sim card is active. And have rebooted the system multiple times.

Any help is appreciated.

Thank You

Hi @matthew-1985 ,

Could you try with username and password with the command below?

sudo ./quectel-CM -s internet.com wapuser1 wap pap

Hi ensar, thank you for the quick response.

I booted up the pi and tried your recommended command and the process gets hung up after the ‘ifconfig wwan0’ line (See Output1), as this was a new error, I tried the previous commands as well and received the same new issue. I’ve once again provided the outputs from the different recommended commands (Attached below) and the first thing I noticed is a change to the response in the AT+CGREG and AT+CREG commands that output (0,2) now.

Thanks again for your help

+CGREG: 0,2 / +CGREG: 0,0
+COPS: 0

indicates, you are not registered on the network.

Thank you for the response,

I have already checked the sim with the carrier and they say there shouldn’t be an issue with the sim card. The fact that the response from the CREG earlier was 0,1 and after reboot is now 0,2 somewhat confirms the fact that the sim is registered.

Are there potentially other reasons for this error?

Thank you

Could you please share the following AT command outputs?


Also, please confirm the APN, username and password etc. information with your provider.

Thank you for the consistent support.
I’ve crossed checked the apn and it should be ltemobile.apn which is listed on the proovider’s website and is also confirmed by the success in this post QMI – Raspberry Pi 4G/LTE Cellular Modem Kit – Pi 3B+, Rogers (Ontario, Canada) - #3 by bighead
Below are the outputs from the AT commands.
Thanks again for investigating this issue.

Update to the error:

The CREG is back to outputting 0,1 and I am back to the same issue as the initial post. I tried ensar’s original suggestion and I receive the same error as the initial post.

Basically, I am back to the ‘requestSetupDataCall’ hang up

If there is some documentation to the details of this function, that would be helpful.

Thank you,

Update again,

Everything seems to be working. For those who are using Rogers in Canada there are three APN possibilities.

On an arduino project I was doing, the APN I used was internet.com
Then from this link: Rogers: Manage Your Experience there are two more options, ltemobile.apn and ltedata.apn.

I was nieve earlier thinking it was either internet.com from my past experience or ltemobile.apn because another community member used this apn. However for me it was ltedata.apn. No user or password.

Hope this helps others in the future.

Thanks again for the support along the way, much appreciated


Hi matthew-1985,

I am considering going down the SixFab path to provide cell service to multiple Raspberry Pi. In order to do this economically i want to use my already active Rogers sim cards. I am already using other MiFi devices but feel that an onboard solution will be more dependable and less power hungry. So in your experience it is possible to successfully use a Rogers sim card instead of the SixFab sim solution? Did it really require a lot of extra code to install/activate other than the standard SixFab setup?