Device files keep coming and going every few seconds

I think something is wrong with my setup. I’ve tried both a Thales Cinteron and a Telit FN980m and both of them have this behavior where the devices files (e.g. /dev/ttyUSB0) appear for maybe five seconds and then they disappear for about two seconds and then the pattern repeats. You can see the device coming and going in dmesg but also by just running “ls” on the device file appearance. I have the voltage set for the correct 3.3V, but it just keeps power cycling.

Any suggestions?

I can send the output of dmesg, but it pretty much just shows the device files “attached” and then a few seconds later “disconnected”.

Rick Niles.

Hello Rick,

Do you have modemmanager installed? During our test, we observed similar behavior using Quectel module with modemmanager installed.
Please remove it using
sudo apt purge modemmanager

Yikes, if I remove modemmanager how is going to connect to the network? That’s the essential element I’ve been using for my other 5G hardware.

I can confirm that if remove modemmanager then the behavior stops. However, now while the device is present and persistent is not registered on the network. When I use other modem solutions, modemmanager is the way it automatically joins the network…with these SAME modems. So please forgive my ignorance, but how do bring up the interface without modemmanager? I can force in to “up” status with “ifconfig wwan0 up” but that’s not useful as it has no IP address, etc. Any pointers to additional documentation on the Internet would be appreciated. :). Thanks.

Hello @gnupooh

Removing modemmanager is what the module’s OEM Quectel strongly suggests to make all of their modules work on Linux. The modemmanager conflicts with the way the module operates.
You can either use quectel cm-tool or the ECM.

  • For the ECM: Once the module is correctly configured, it will behave like ethernet and will connect automatically. All you need after booting the RPi, is to turn on the module by driving FCPpin(GPIO26) to HIGH.

  • For Quectel CM tool: you will need to follow the instructions and need to write a script for establishing the connection at RPi boot.

You can find the module’s documentation here.
Since it is a new module you may also keep yourself posted with other users from Quectel’s forum.

Sorry I didn’t realize this part would be modem specific. I’m using the Telit FN980m not the Quectel. I’ve tried this module with both the Telit developer kit and the Timack NGFF(M.2) to USB 3.0 Adapter with Dual Nano SIM Card Slot from Amazon for ($30) and they both work perfectly with modemmanager. I don’t need to do anything to bring up the network.

A quick search of the TLA “ECM” in Google finds me the following Linux related tools:

  • Red Hat Enterprise Configuration Manager (ECM)
  • Extra CMake Modules
  • Executable Compression Module
    …and few other even more obscure references. I don’t think any of these are quite the right thing you’re trying to direct me to. Any pointers would be appreciated.


Did you switch the Module Voltage Select correctly?

For Telit, it should be 3.3V.