Cellular Connection Unavailable

I’m using the 4G/LTE Base Hat with the Telit LE910C1-NF. I had it all working, and it was able to talk to the internet over the wwan0 interface… Then yesterday for some reason it has stopped working. I still get an IP address on wwan0 and a route to the outside via the gateway, but it can no longer communicate:

$ ping -I wwan0 google.com
PING google.com ( from wwan0: 56(84) bytes of data.
From ( icmp_seq=1 Destination Net Unreachable
From ( icmp_seq=2 Destination Net Unreachable

According to Sixfab Core, the device is online, but the cellular connection status says “Cellular Connection Unavailable”. It says my roaming operator is AT&T.

It seems there might also be an issue with ECM initialization, though it’s not clear:

$ tail logs/cm-log 
2021-03-18 18:22:27,663 --> modem.py       INFO     APN is up-to-date.
2021-03-18 18:22:27,665 --> modem.py       INFO     Checking the mode of modem...
2021-03-18 18:22:30,305 --> modem.py       INFO     Checking the network is ready...
2021-03-18 18:22:30,997 --> modem.py       INFO     SIM is ready.
2021-03-18 18:22:31,657 --> modem.py       INFO     Network is registered.
2021-03-18 18:22:41,669 --> modem.py       INFO     Checking the ECM initialization...
2021-03-18 18:22:42,354 --> modem.py       INFO     ECM Connection is initiating...
2021-03-18 18:22:49,167 --> cm.py          ERROR    initiate_ecm() -> ECM initiation failed!
2021-03-18 18:22:49,369 --> modem.py       INFO     Checking the ECM initialization...
2021-03-18 18:22:50,060 --> modem.py       INFO     ECM is already initiated.

Also when doing those ping tests that are failing, it still shows up in the sixfab dashboard as data usage which is charging me, even though the communication is failing.

How best can I get this working again? Perhaps something got goofed up and there’s a way to “factory reset”?

Hi @defermat ,

Could you please provide us with the following information(logs&files):

  • All logs of core_manager and core_agent services
  • /home/sixfab/.core/logs/agent-log
  • /home/sixfab/.core/logs/cm-log
  • Raspberry Pi Model

Sixfab Core services have a recovery mechanism. It does this for you.

Could you please update the module firmware first?
ECM problems fixed in the new firmware. Maybe the problem is with that.

Please see the product page for firmware.

Hi @ensar,

According to Sixfab Core I’m running: M0F.260006

I uninstalled the Core as it kept disconnecting my serial connections when trying to execute commands for GPS separately. I wasn’t able to get ECM mode to work, but reconfiguring it for PPP works.

Well, if you want, you can install Core again after updating the firmware.

If the ECM problem persists, try the firmware here:

Can you point me to instructions for updating the firmware? I have the module on a Raspberry Pi running Raspbian, but the firmware you linked is an .exe for Windows.

You need Windows to update the module firmware.

  • Connect the HAT to the host Windows machine.
  • Install the USB Driver for Windows Desktop(Download the driver from the product page).
  • Finally, run the .exe file in the firmware file(.zip).

Hi, I’m newer. I’m using the 4G/LTE Base Hat with the Telit LE910C1-EU. I got the same problem I install Core on my raspberry pi 3B+ but on the sim card management site (https://connect.sixfab.com) I see that I was only able to use eth0 not the 4G module. I saw Last Cellular Connection Status: Cellular Connection Unavailable.
My sim card is activated. So I tried to follow this guide Internet Connection with Telit LE910C1 module using ECM Mode (sixfab.com) but I got an error with the AT cmd AT#ECM=1,0. I made the process twice without Core installed.
I tried also to update the firmware but on the site you mentioned the file can’t be download.
If you have any advice, thanks you !