3G/4G & LTE Base Hat USB connection and power supply

Good morning,

we are using a Raspberry Pi 3G/4G & LTE Base Hat, together with a Quectel EG25-G module.

We have seen, in the proper documentation section on your website, that there is the possibility to power-up the Base Hat and the Quectel module with an external 5V source.

Given the external 5V power source, if we connect the Base Hat to a Raspberry Pi 4 through the proper USB cable for data communication, where does the Base Hat take the power supply from?

Performing a test of the above case, we’ve seen that the power supply of the Base Hat is eventually taken from the USB connection. Could you please confirm (or not) that?

Would it be possible to “split” the power supply signals from the data communication signals of the USB connection from the Base Hat to Raspberry Pi (realizing a proper USB cable), powering-up the Base Hat through an external source and keeping the whole system working?

Thanks in advance for your replies.

Best regards

Hi @Andrea_Sqy,

Yes, we confirm it.

This can be done by removing the fuse from the HAT, as shown in the following figure.
Once it is removed, the 5V of USB will not power the Base HAT.


Hi @ensar,

thanks a lot for your answers, your help has been much appreciated.

Best regards

I just tried to power the HAT from external source with 5V.
First, I removed the fuse as pointed in the image. Then I stacked the hat on the raspberry pi 4b, and it does not work. The raspberry stops working. I can see the rainbow when starting the pi. So there is something wrong.

Also, I cannot see the red light in the power LED of the HAT .

Then I removed the hat, and the raspberry worked again.

I doubled checked the power supply and the polarity in the external power pins of the HAT.

Can you confirm that the hack you provide is currently working?


Hi @bramez ,

have you tried keeping the setup you described (external power supply to the HAT and fuse removal), but without plugging the HAT into RPi headers (i.e., connecting the HAT to the RPi only through USB cable)?

Hi Andrea,
yes I also tried that. I have doubled check the scenario you mention right now.
The HAT does not show any lights which may indicate it is being powered ( no LEDs on) and and the raspberry does not detect the HAT+quectel EC25.

Hi @bramez ,

ok, but in this configuration the RPi does work, which is a first point.

If the power led on the HAT is off even if the external voltage is supplied, I would check the “power-supply part” of the setup, even if I read that you already checked it…If all is correct, it should work.

Not knowing other details of your setup, what I can suggest is to check also the maximum current that your Power Supply (PS) is able to feed. Choose a PS with at least 3A of maximum current.

There is an image showing an example of power-supply connection at this link, while other technical details are described here.

Hello @bramez ,

Could you please share a clean closeup image of Top and Bottom of the HAT alone?
Plugging 5V without RPi, module should lit the Power LED.

Hi Andrea, Saeed.
my power supply is configured to supply 5V and 10A (maximum).

I attach closeup images of the HAT. I don’t have the connector, but I soldered a couple of cables . I can power externaly the HAT provided I don’t remove the fuse you point in the image. Once I remove the fuse, nothing works.

The rating for the voltage regulator is 5V 3A max.

Yes, I’m supplying 5V with a current limitation of 10A. Which means, that the load ( HAT + quectel ec25 ) will drain as much current as it may need with no limitation on the power supply, but in this case the 3A limitation of the voltage regulator. I don’t see any problem in this setup.

Can you see anything bad in the pictures?

There is nothing odd visible on the HAT.
Are you getting this behavior from all of your Base HATs?

Just for a quick test, you can keep the Base HAT unstacked from the GPIO header. Then connect the 5V and GND from the GPIO Headers and check if the HAT powers up.

PS. I doubt the voltage regulator got damaged.

I tried 2 Base Hats. Both with the same behaviour. First I thought there was a problem with the first hat, but I got the same behaviour with the second hat.

Both are unstacked.

I just tried connecting 5V and GND from GPIO Headers. It does not power up.

Could you show me the location of the voltage regulator? I can test if voltage is veing regulated properly.

Here is the regulator.

The pinout:

Hi Saeed,
The voltage regulator is not working. It receives the 5V , but it cannot deliver 3,3V, but 0V.

I have some other Base Hats. Is it safe to remove the fuse to use external supply or will it damage the voltage regulator again?



Could you please make sure the GPIO 26 pin is low or connected to GND?
If this pin is HIGH, the regulator will turn off.

Hi, could you please provide the part number of the board connector shown in this image?

I would also like to power my module from a different source than the USB bus.


Hi @ramonvp,

Here is the part used for the connector: https://www.digikey.com/en/products/detail/jst-sales-america-inc/S2B-PH-SM4-TB-LF-SN/926655?s=N4IgTCBcDaIM5gEYFoAOALZcC2AWZALoiALoC%2BQA


Hi Saeed, I have removed the fuse on all my HATs. I have tested the HATs + EC25 quectel module and they work fine. However, they have now stopped working.

What I did:

  1. Remove the fuse
  2. Power the board with 5V from USB-C charger
  3. Use the HAT+ Quectel EC25 successfully.
  4. Power everything off.

Next day, 6 out of 7 boards do not work anynore.

GPIO26 is connected to to GND.

I have checked voltage regulator, and it has GND and 5V at the input pins, but 0V at the output.

Could you let me know the model of the voltage regulator? I would like to check specs.

Moreover, it is weird that all boards stopped working the same day, I have severl power supplies, so I checked with different ones.

Lastly, Is it safe to power the board directly with USB-C charger? If not, could you please recommend some protection circuit?

I am kinda confused, because I have not been able to operate normally with USB cable powering the hat + quectel EC25E, and the only solution I found was to power the board with external USB-C power 15W (5V/3A).


Hello @bramez,

Here is the datasheet of the regulator used on the HAT.

Could you please share the image of your whole setup?