Unable to connect to APN using quectel-CM script for EC-25AU module

Hi All,

I am using an EC-25AU module to with a 3G/4G/LTE Base HAT.
So far I was able to connetc to the LTE data service using the quectel-CM script and the wwan0 interface was able to get an IP address.
But recently I am unable to connect using the script and it is showing below error while connecting.
QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)

Any idea what might be the issue? I already restarted the Pi and the modem but the same issue observed.
I tried switching from LTE to 3G and vise versa but getting a similar results.

pi@raspberrypi:~/files/quectel-CM $ sudo ./quectel-CM -s telstra.wap
[06-08_21:24:08:621] WCDMA&LTE_QConnectManager_Linux&Android_V1.1.45
[06-08_21:24:08:622] ./quectel-CM profile[1] = telstra.wap///0, pincode = (null)
[06-08_21:24:08:623] Find /sys/bus/usb/devices/1-1.1 idVendor=2c7c idProduct=0125
[06-08_21:24:08:623] Find /sys/bus/usb/devices/1-1.1:1.4/net/wwan0
[06-08_21:24:08:623] Find usbnet_adapter = wwan0
[06-08_21:24:08:624] Find /sys/bus/usb/devices/1-1.1:1.4/usbmisc/cdc-wdm0
[06-08_21:24:08:624] Find qmichannel = /dev/cdc-wdm0
[06-08_21:24:08:644] cdc_wdm_fd = 7
[06-08_21:24:09:645] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:11:645] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:13:645] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:15:645] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:17:646] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:19:646] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:21:646] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:23:647] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:25:647] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:27:647] QmiThreadSendQMITimeout pthread_cond_timeout_np=110, errno: 22 (Invalid argument)
[06-08_21:24:28:647] main Failed to QmiWwanInit: 22 (Invalid argument)
pi@raspberrypi:~/files/quectel-CM $

Best Regards,
Motahar

Hello,

The Module OEM, mentions the symptom could be due to the USB port drop.
and suggested to use the latest quectel-CM tool.

We will update the CM tool for easy installation and run required test by next week.

Hi,
Thanks a lot for your response. As you suggested I tried to update the CM tool but looks like there is some issue with the permissions.
according to the below instructions:


step 12. gives me permission denied. so I had to be root to run ./quectel-CM.
previously I was able to browse files/quectel-CM using sudo only.
Please note I tried this same steps with a freshly installed Raspbian SD card as well.

pi@raspberrypi4:~ $ cd files/quectel-CM
-bash: cd: files/quectel-CM: Permission denied

Then when I tried to configure Auto Connect on reboot steps and installed sudo ./install_auto_connect.sh the service is not running though I provided the APN correctly.

pi@raspberrypi4:~ $ sudo systemctl status qmi_reconnect.service
● qmi_reconnect.service - QMI Auto Connection
Loaded: loaded (/etc/systemd/system/qmi_reconnect.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2020-07-06 13:57:24 AEST; 36s ago
Process: 1491 ExecStart=/bin/sh /usr/src/qmi_reconnect.sh (code=exited, status=200/CHDIR)
Main PID: 1491 (code=exited, status=200/CHDIR)

Jul 06 13:57:24 raspberrypi4 systemd[1]: qmi_reconnect.service: Service RestartSec=100ms expired, scheduling restart.
Jul 06 13:57:24 raspberrypi4 systemd[1]: qmi_reconnect.service: Scheduled restart job, restart counter is at 6.
Jul 06 13:57:24 raspberrypi4 systemd[1]: Stopped QMI Auto Connection.
Jul 06 13:57:24 raspberrypi4 systemd[1]: qmi_reconnect.service: Start request repeated too quickly.
Jul 06 13:57:24 raspberrypi4 systemd[1]: qmi_reconnect.service: Failed with result ‘exit-code’.
Jul 06 13:57:24 raspberrypi4 systemd[1]: Failed to start QMI Auto Connection.
pi@raspberrypi4:~ $

Please suggest.

I’ve the same issue.

Using command as below, I was able to get internet.
sudo su
cd files/quectel-CM
sudo ./quectel-CM -s internet

But using the auto reconnect script, I’ve the same error massage.

Hi,
I tried to change the permission of the quectel-CM folder into read & execute for group & public.

it shows that quectel-CM permission was set to rwx------
then I changed it to “sudo chmod 755 quectel-CM”
then I am able to so cd files/quectel-CM and execute the script.

It happens after the updated the QMI.
Thanks.

Hi,
If quectel-CM directory is located in /home/pi/files change the /usr/src/qmi reconnect.sh script to the following:

#!/bin/sh

while true; do

    ping -I wwan0 -c 8.8.8.8

    if [ $? -eq 0); then
         echo "Connection up, reconnect not required..."
    else
         echo "Connection down, reconnecting..."
         sudo /home/pi/files/quectel-CM/quectel-CM -s  #your APN
    fi

    sleep 10
done

Check the WorkingDirectory path in the /etc/systemd/system/qmi_reconnect.service file.

then follow these:

  1. systemctl daemon-reload

  2. systemctl start qmi_reconnect.service

  3. systemcrl enable qmi_reconnect.service