UART Connection on Base Hat

Is there any success in getting UART connection to work on the Base Hat?
I am using the EC25 Module. IT works fine over USB but now I need UART and it worked fine on the IoT hat.
I tried everything same as in this thread - How can I use UART with Raspberry Pi 3G/4G&LTE Base HAT?

For anyone messing with UART - here is some handy info: UART configuration - Raspberry Pi Documentation

I did have some success and got the Base Hat to work over UART (and much slower speed as to be expected). Not sure how I git it to work.

First I followed the setup for ECM over USB and that works fine for the Quectel EC25.

Then, minicom -D /dev/ttyUSB2 -b 115200 (bus use ttyS0 instead for UART)

The modem would not respond to AT commands but no internet.

I ran minicom -s and set serial to ttyAMA0 then back to ttyS0.

No luck so then I ran this here (same as for IoT Hat) but setup for 3G/4G Base Hat for PPP.

Make sure to set ttyS0 (not USB)

I rebooted then it would still only work on USB. Then I unplug the USB and reboot again and now it is working on UART. Yeah!!

My question now is what Is the proper documentation for setting up ECM vs. PPP vs. QMI ?

Make sure to solder the jumpers on the back! :slight_smile:

If you want to use the 3G/4G Base Hat via UART it will work with PPP and QMI OK. Keep in mind it will be much slower this way. Preferably you want to use USB to take full advantage of the fastest speeds. ECM protocol will work only over USB.