Trouble setting up Internet Connection with Telit LE910C1 module using ECM Mode

Trying to setup an internet connection on Raspberry Pi following the guide at:

After running:
sudo apt install minicom -y

Have verified that minicom is installed, however, running command:
minicom -D /dev/ttyUSB2 -b 115200

Results in:
minicom: cannot open /dev/ttyUSB2: No such file or directory

Also, running command:
ls /dev/ttyUSB*

Results in:
ls: cannot access '/dev/ttyUSB*': No such file or directory

It seems there is no entry for this device.

Have confirmed that modem is visible by running lsusb, which shows:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 014: ID 1bc7:1205 Telit Wireless Solutions LE910C4-AP
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Have tried running this in command line:
pi@raspberrypi:~ $ AT#USBCFG=0

Which results in:
bash: AT#USBCFG=0: command not found

Any tips to help in getting the device to show up and working?
Thanks :slight_smile:


This happens when the USB configuration is set to 3 i.e. PID 0x1205 which doesn’t contain any USB interface

The solution has been discussed in the following thread.
Error installing Telit LE910x using ECM

Thanks so much for your suggestion @saeed :grinning:
I will definitely look into that and report back.

I have tried this, which helped in getting to the next stage: I can get onto Minicom

However, after continuing to follow the rest of the setup guide (Internet Connection with Telit LE910C1 module using ECM Mode) I am still unable to get an internet connection.

Tried the troubleshooting commands, getting the following response:


#ECM: 0,1


+CREG: 0,1

+CGDCONT: 2,"IPV4V6","","",0,0,0,0
+CGDCONT: 3,"IPV4V6","ims","",0,0,0,0

The SIM is using the Tesltra network in Australia.
The APN was taken from a USB modem setup page - it works properly with this same SIM card in the USB modem.

Is @saeed or anyone else able to help from here?
Thanks again :slight_smile: