Trouble connecting to the internet via BASE HAT and Quectel EC25E

Hi, I’m trying to connect my raspberry pi for a remote project with my high school and I followed the tutorial which worked well until I ran the command to connect to the internet.
Downbelow you can see the output a got from the terminal. It is my first time using this HAT so I have no idea what I am looking at or what to do now!

pi@raspberrypi:~/files/quectel-CM $ sudo ./quectel-CM -s
[09-16_17:16:23:508] Quectel_QConnectManager_Linux_V1.6.0.12
[09-16_17:16:23:510] Find /sys/bus/usb/devices/1-1.4 idVendor=0x2c7c idProduct=0x125, bus=0x001, dev=0x004
[09-16_17:16:23:511] Auto find qmichannel = /dev/cdc-wdm0
[09-16_17:16:23:511] Auto find usbnet_adapter = wwan0
[09-16_17:16:23:511] netcard driver = qmi_wwan, driver version = 22-Aug-2005
[09-16_17:16:23:511] ioctl(0x89f3, qmap_settings) failed: Operation not supported, rc=-1
[09-16_17:16:23:512] Modem works in QMI mode
[09-16_17:16:23:532] cdc_wdm_fd = 7
[09-16_17:16:23:626] Get clientWDS = 20
[09-16_17:16:23:658] Get clientDMS = 1
[09-16_17:16:23:690] Get clientNAS = 4
[09-16_17:16:23:722] Get clientUIM = 1
[09-16_17:16:23:754] Get clientWDA = 1
[09-16_17:16:23:787] requestBaseBandVersion EC25EFAR06A04M4G
[09-16_17:16:23:915] requestGetSIMStatus SIMStatus: SIM_READY
[09-16_17:16:23:915] requestSetProfile[1]
[09-16_17:16:23:979] requestGetProfile[1]
[09-16_17:16:24:011] requestRegistrationState2 MCC: 240, MNC: 2, PS: Attached, DataCap: LTE
[09-16_17:16:24:043] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
[09-16_17:16:24:043] ifconfig wwan0 down
[09-16_17:16:24:057] ifconfig wwan0
[09-16_17:16:24:107] requestSetupDataCall WdsConnectionIPv4Handle: 0x87203c20
[09-16_17:16:24:235] ifconfig wwan0 up
[09-16_17:16:24:247] busybox udhcpc -f -n -q -t 5 -i wwan0
udhcpc: started, v1.30.1
No resolv.conf for interface wwan0.udhcpc
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: no lease, failing
^C[09-16_17:17:15:812] requestDeactivateDefaultPDP WdsConnectionIPv4Handle
[09-16_17:17:15:819] ifconfig wwan0 down
[09-16_17:17:15:835] ifconfig wwan0
[09-16_17:17:16:011] QmiWwanThread exit
[09-16_17:17:16:011] qmi_main exit

With best regards Samuel!

To follow up I solved this problem by following these instructions at SOLUTION to failed to get dhcp lease