Telit LM960A18 on Raspberry Pi 3G/4G & LTE Base HAT

Has anyone tried the Telit LM960A18 Cat 18 modem with the Raspberry Pi 3G/4G & LTE Base HAT?

Hello @mr.salas77515, I have just ordered one yesterday and it should arrive by end of week!

I will let you know about it!

Please do and thanks in advance.

Got the module… But the wrong cables to hook up the antennas to it. (:

For those with intention to get it: the antenna connectors on the LM960 are not u.FL, they are I-PEX MHF4 (looks like u.FL but even smaller). So the antenna cables that SixFab sell are not compatible.

Any luck or still waiting on your cables?

They’re on the way, should be there next week - had to take the slow shipping option cause most my money went into the LM960 already :sweat_smile:

How’s that project coming? Any results? Thanks.

Hey @mr.salas77515 sorry for not updating - I still don’t have my SMA to IPEX MHF4 cables to hook the LM960 to my antennas yet…

Reason for that is that Digikey does not have stock for the ones I ordered and thus pushed my lead time to December…

I’ll update back once I finally got those or others, rest assured!

Dont know where your located but have you checked ? They usually have in stock. Just FYI.

I’m based in Northern Europe and I think LTEFix is more US-based so wouldn’t really be convenient…

That being said, Digi-Key is also shipping from US so it really does not matter (:

At last though, they filled in my order with SMA-IPEXMHF4 cables from a different brand (PulseLarsen) which should be arriving next week, according to tracking - that said, it’ll come in 2 shipments because of some fuckup where they shipped 3x cables only (arriving 10/5) and then only 1x other separately (ETA unknown still)…

My advice: avoid buying from them and if you do ask before ordering if they have the stuff on stock because their website will say they do and then you get an email saying it’s not anymore…

To be continued…

Got it. I’m on the Texas Gulf Coast (USA). Keep in touch,

I can’t believe it’s been 17 days since we last spoke and I still don’t have my cables…

My order has been held up by customs for the past 2 weeks and Digikey support has been inexistant, to say the least. Only today I received some automated email from them advising me that it’s being held up - yeah no joke I’ve been seeing it on my shipment tracking app for 2 weeks!

I’ve asked for a full refund and will order with Techship (where I got my LM960) which is Sweden-based and they have SMA IPEXMHF4 cables in stock.

As always, I’ll keep in touch… :unamused:

Man, tuff to get supplies these days. Anyway thanks for the update. Looking forward to your success.

Finally got the right cables to hook up my LM960 to antennas!

Did some preliminary testing with it and was able to establish internet connection not using SixFab’s guide (QMI Interface Internet Connection Setup Using Sixfab Shield/HAT) because it threw me some errors midway…

Instead, I followed Techship’s guides here and they worked:

  1. Techship - FAQ - How-to automatically set up and maintain the cellular data connection in headless Raspberry Pi OS / Raspbian systems?
  2. Techship - FAQ - Using NetworkManager and ModemManager in Linux to automatically establish and maintain a connection

Issue I’m having now: after reboot, the wwan0 interface disappears - most likely due to conflict between ModemManager, NetworkManager and Raspbian’s dhcpcd despite having added denyinterfaces wwan0 to my /etc/dhcpcd.conf as instructed here (Techship - FAQ - We cannot acquire an DHCP address over qmi_wwan driver when using Raspbian Linux OS?)…

Other than that, it “works” - let me know if you have any questions (or solutions to my issues)!