Sixfab Cellular IoT Hat not powering on

Out of the blue my hat stopped turning on. it was working fine until recently. I left it off for several days and when I tried to use it today it wouldn’t turn on. Tried different raspberry’s.

Tried via software and via the powerkey button on the hat.

Any advice on how to troubleshoot this? I have this for less than 6 months.

Hi @muanis ,

How is the POWER LED of the HAT behaving?
Is it turned on? If not, please check the Disable Pin(GPIO17) of the HAT. Make sure the pin is at LOW state.
Just to confirm if the issue is with the LED itself, are you able to see the module details in the output of lsusb?
How long did you press the power key? Try pressing it for 2 seconds.

Power Led is on.
Nothing happens when I press the power button. I did run this piece of code

import RPi.GPIO as GPIO
import time
import os

GPIO.setup(23,  GPIO.IN)
state = GPIO.input(23)

GPIO.setup(17,  GPIO.IN)
pin17 = GPIO.input(17)

if (state):
    print('Radio is Off')
    print('Radio is On')

if (pin17):
    print('Radio is enabled')
    print('Radio is not enabled')

    print("trying to enable")
    GPIO.setup(17, GPIO.OUT)
    GPIO.output(17, GPIO.LOW)

    GPIO.setup(17,  GPIO.IN)
    pin17 = GPIO.input(17)

        print("radio is now enabled")
        print("radio is still disabled")

And the radio wouldn’t turn on. But then when I presser power for 2 seconds it worked.

And all my scripts to turn it on and send messages are working now.