Sixfab Base Hat USB disconnect loop

Hello, we’ve recently purchased the Sixfab Base HAT with the Telit ME910C1-WW cellular module and a few Sixfab SIM cards for a Raspberry Pi based project. After following the quick start guide, installing the Core software and registering the SIM on the connect.sixfab.com website, the HAT looses a connection to the Raspberry Pi USB interface every 30 seconds or so.

At first, it all seems to be working
wwan0Connected

lsusb shows the Telit modem connected
lsusb1

after 30 seconds or so the wwan0 interface is disconnected
wwan0disconnected

at that moment lsusb shows the Telit modem is no longer connected
lsusb2

dmesg shows the disconnection and reconnection details

I’m not sure if this is a power issue but i’m using the 3a Supply that came with the Raspberry Pi and have the Sixfab base hat connected with the supplied USB cable that came with the Base HAT. No other hats are connected to the Raspberry Pi.

I’ve tried the Base HAT on 3 Raspberry Pi 4B+, all with the same results.

Any ideas or help would be greatly appreciated.
Thanks in advance

Hi @cmlove ,

Thanks for reaching out!
We have tested this issue again and we don’t exactly know where the problem lies, but we are working on it. It’s difficult to say anything else about it at the moment. I will inform you as soon as we know more.

Hi,
I am facing the same problem than @cmlove . I have 10 devices with this setup:

Raspberry Pi 4 4GB
Sixfab Base HAT LTE
Quectel EC25-E
External power (5V/3A) for the HAT + Quectel EC25-E
USB cable to communicate Raspberry and Base HAT + Quectel EC25-E

At first I thought it was a power issue, as the technical specs for Quectel EC25-E say that the device may consume > 2A. I used then a dedicated 15W power supply. (5V/3A) to feed the Sixfab Base HAT + Quectel EC25-E.

However, Ubuntu 20.01 in Raspberry pi 4, loses the USB connection

And the modem is no longer visible (lsusb -t show no quectel device).

I am wondering if raspberry pi 4 + sixfab Base HAT + Quectel EC25-E is a valid setup. Obviously it is not working and the reliability is pretty poor.

@ensar, I have contacted several times with Sixfab support, but never acknowledged any problem (disconnection issues). Now, after spending hours and hours with this problem I am pretty sure there is an issue somewhere in this setup.

Quectel does not support Raspberry + Quectel EC25 setup.

What is your recommendation at this point?

Hi @bramez ,

Which FW is currently on the module?
There is an OEM reported FW version with a similar issue, maybe you have that FW.

Hi @ensar
We currently have an official version from quectel, which is working in other projects. The firmware version is: EC25EFAR06A01M4G_TEL

USB disconnection is one of the known issue in previous FWs which was resolved in R06A09 FW version.
Since your modules are running on pretty old FW, please upgrade them.

R06A11 FW link: https://drive.google.com/file/d/1JcdMrY9axNTw77xx-cLcl2eti2wBzFmK/view?usp=sharing

FW upgrade tool for Linux: https://drive.google.com/file/d/1zBG1PkvBT6VBS-1NHqi3fewCET6H8JvP/view?usp=sharing

These are the firmwares that we have tried:

  • EC25EFAR06A11M4G_01.001.01.001
  • EC25EFAR06A01M4G_TEL_01.001.01.001. —>This is certified by another department in Telefonica, that’s why we are using it.
  • EC25EFAR08A02M4G_01.001.01.001

All of them have the same issues. Therefore, I guess it is something else.