Sixfab 5G Modem Kit - No cellular service

Hi,

I’m following the Getting Started guide but have had no success establishing a cellular network connection.

I’m using a prepaid SIM from Super (Telia) in Estonia. The SIM card is activated and works well on an Android phone. However, when I use the same SIM on the Sixfab 5G modem kit, I can’t establish a cellular connection.

(env) pi@digipi:~ $ atcom AT+CGDCONT=1,\"IPV4V6\",\"internet.emt.ee\"
AT+CGDCONT=1,"IPV4V6","internet.emt.ee"
OK

(env) pi@digipi:~ $ atcom AT+CFUN=1,1

(env) pi@digipi:~ $ ping -I usb0 sixfab.com -c 5
ping: sixfab.com: Temporary failure in name resolution

(env) pi@digipi:~ $ ping -I usb0 104.21.94.205 -c 5
PING 104.21.94.205 (104.21.94.205) from 192.168.225.50 usb0: 56(84) bytes of data.
From 192.168.225.1 icmp_seq=1 Destination Net Unreachable

(env) pi@digipi:~ $ ifconfig usb0
usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.225.50  netmask 255.255.255.0  broadcast 192.168.225.255
        inet6 fe80::a3f6:6af2:e677:f3de  prefixlen 64  scopeid 0x20<link>
        ether 8a:90:b5:58:a4:bb  txqueuelen 1000  (Ethernet)
        RX packets 190  bytes 11306 (11.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 254  bytes 19967 (19.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

(env) pi@digipi:~ $ atcom AT+QGMR
AT+QGMR
RM502QAEAAR11A04M4G_01.202.01.202

OK

(env) pi@digipi:~ $ atcom AT+CGDCONT?
AT+CGDCONT?
+CGDCONT: 1,"IPV4V6","internet.emt.ee","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 3,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1,,,,,,,,,"",,,,0

OK

(env) pi@digipi:~ $ atcom AT+CFUN?
AT+CFUN?
+CFUN: 1

OK

(env) pi@digipi:~ $ atcom AT+CPIN?
AT+CPIN?
+CPIN: READY

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG=\"mode_pref\"
AT+QNWPREFCFG="mode_pref"
+QNWPREFCFG: "mode_pref",AUTO

OK

(env) pi@digipi:~ $ atcom AT+QENG=\"servingcell\"
AT+QENG="servingcell"
+QENG: "servingcell","LIMSRV","WCDMA",248,03,CD,D7F8E,10663,210,205,-69,-6,-,-,-,-,-

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG=\"nr5g_disable_mode\"
AT+QNWPREFCFG="nr5g_disable_mode"
+QNWPREFCFG: "nr5g_disable_mode",0

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG=\"nr5g_band\"
AT+QNWPREFCFG="nr5g_band"
+QNWPREFCFG: "nr5g_band",41:77:78

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG=\"nsa_nr5g_band\"
AT+QNWPREFCFG="nsa_nr5g_band"
+QNWPREFCFG: "nsa_nr5g_band",2:41:66

OK

(env) pi@digipi:~ $ atcom AT+QNWINFO
AT+QNWINFO
+QNWINFO: No Service

OK

(env) pi@digipi:~ $ atcom AT+COPS?
AT+COPS?
+COPS: 0

OK

(env) pi@digipi:~ $ atcom AT+CGACT?
AT+CGACT?
+CGACT: 1,0
+CGACT: 2,0
+CGACT: 3,0

OK

(env) pi@digipi:~ $ atcom AT+CGPADDR=1
AT+CGPADDR=1
+CGPADDR: 1,""

OK

(env) pi@digipi:~ $ atcom AT+CREG?
AT+CREG?
+CREG: 0,0

OK

As a newbie to cellular networks, I would appreciate some guidance for further debugging.

Thank you!

Hi,

  • Please check Signal Strength: Use the following command to check the signal strength:
AT+QENG="servingcell"
  • Try to force the modem to re-register on the network:
atcom AT+COPS=0

After this, check the registration status again with:

atcom AT+CREG?

The response should ideally be +CREG: 0,1 (registered, home network) or +CREG: 0,5 (registered, roaming).

  • Manual Operator Selection: List available operators to ensure your modem sees the network:
atcom AT+COPS=?

If your operator is listed, try registering manually:

atcom AT+COPS=1,2,"24803"  # Replace "24803" with the appropriate network code for Telia Estonia.

Then check the registration status again:

atcom AT+CREG?
  • Ensure that your APN settings are correct and properly applied.

  • Power Cycle the Modem: Sometimes a power cycle can help:

atcom AT+CFUN=1,1

Thank you for your reply, @ensar.

Signal Strength Check

atcom AT+CSQ in fact gave me 99 for rssi.

SIM Card Swap and Connection Attempt

I swapped the Telia (Super) SIM card for an Elisa SIM card and was able to get a connection. Below are the details of the commands and their responses:

(env) pi@digipi:~ $ atcom AT+CSQ
AT+CSQ
+CSQ: 19,99

OK

(env) pi@digipi:~ $ atcom AT+COPS=?
[ERR]   Timeout, couldn't get response

(env) pi@digipi:~ $ atcom -t 60 AT+COPS=?
+COPS: (1,"Elisa EE","ELISA","24802",2),(1,"Elisa EE","ELISA","24802",12),(3,"Tele2 EE","Tele2 EE","24803",2),,(0-4),(0-2)

OK

(env) pi@digipi:~ $ atcom -t 60 AT+COPS?
AT+COPS?
+COPS: 0,0,"Elisa EE elisa EE",2

OK

(env) pi@digipi:~ $ atcom -t 60 AT+CREG?
AT+CREG?
+CREG: 0,1

OK

(env) pi@digipi:~ $ atcom AT+QENG="servingcell"
AT+QENG="servingcell"
+QENG: "servingcell","NOCONN","WCDMA",248,02,3FD,C9DEA4,2958,83,121,-84,-7,-,-,-,-,-

OK

Connection Issues

No matter where I try to connect (brought my Raspberry Pi to many different places), I can only connect to the WCDMA network. I also tried changing the SIM card to other operators (Tele2) and still only got WCDMA. At the same locations, my cellphone and my colleague’s phones get 4G and 5G connections from Tele2, Telia, and Elisa. For the Sixfab hat:

  • Tele2: only WCDMA
  • Elisa: only WCDMA
  • Telia: no connection at all. Telia shut down its 3G network by the end of 2023, so that’s probably why. But they have pretty good 4G/5G coverage in my area.

Additional Info

(env) pi@digipi:~ $ atcom AT+QNWINFO
AT+QNWINFO
+QNWINFO: "WCDMA","24802","WCDMA_VIII_900",2958

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG="mode_pref"
AT+QNWPREFCFG="mode_pref"
+QNWPREFCFG: "mode_pref",AUTO

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG="policy_band"
AT+QNWPREFCFG="policy_band"
+QNWPREFCFG: "gw_band",1:2:3:4:5:6:8:9:19
+QNWPREFCFG: "lte_band",1:2:3:4:5:7:8:12:13:14:17:18:19:20:25:26:28:29:30:32:34:38:39:40:41:42:43:46:48:66:71
+QNWPREFCFG: "nsa_nr5g_band",1:2:3:5:7:8:12:14:20:25:28:38:40:41:48:66:71:77:78:79
+QNWPREFCFG: "nr5g_band",1:2:3:5:7:8:12:14:20:25:28:38:40:41:48:66:71:77:78:79

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG="rat_acq_order"
AT+QNWPREFCFG="rat_acq_order"
+QNWPREFCFG: "rat_order_pref",NR5G:LTE:WCDMA

OK

(env) pi@digipi:~ $ atcom AT+QNWPREFCFG="nr5g_disable_mode"
AT+QNWPREFCFG="nr5g_disable_mode"
+QNWPREFCFG: "nr5g_disable_mode",0

OK

Request for Further Guidance

Please let me know if there is any additional configuration I should be paying attention to in order to enable 4G/5G connections.

Thanks!