Sim ICCID is already registered

Hello,

I’ve just received my Sixfab core and sim for my RPI4.

When I tried to register my sim something went wrong with the payment method, did not go through.

Now when I try to register it again (on any account) I get the message that its already registered.

Please advise.

Thank you

Hi @Ezra,

Thank you for getting in touch with us.
If you have any questions or concerns please visit the contact page.

Does your SIM appear on your SIM → My SIMs page? Do you want to register the SIM in a different account than the one you saved it for?

Hello,

My bad, my desktop doesn’t display the contact form!

Well when I unboxed the SIM I tried to register but it had not finished properly.

Now from then on, every attempt from any account (tried 1 other, but no need to change accounts) to register the sim it gives me “already registered”.

Thank you for your reply

Could you check if you have a SIM from SIM → My SIMs?

No its empty, no signs that its already actually registered!

Well, could you PM me the SIM ICCID and the e-mail you are logged into?

Sure just a sec. Thanks!