RPI 4G Hat initial configution not working

Hi. I’m having troble at my 4G module configuration. I’m from Mexico and I’m trying to configure this module in a new Raspberry Pi. I followed the github PPP configuration tutorial but the module is still not working. Also, Raspberry does not recognize poff and pon commands even afer running install file.
I’m using Telcel APN.

Hi @edsonrm117,

Please re-install with this tutorial.
And if you get an error, share the output.

Hi, I re-installed with that tutorial and I get no error, Raspberry restarts as supposed to. However, I still can’t connect to internet. I attach images with the provider file, status, ifconfig and etc/ppp/ files

Run the command: sudo systemctl stop reconnect.service
Then share the output of the command: sudo pon

This is the output of sudo pon

Do you need credentials to use your SIM card?

If your carrier asks for username and password;

In a previous image I saw that step, but credentials were already written in this file. Does any other file requieres those credentials?

Does QMI interface work?

I’m not sure, how do I verify that?


I have the exact same behaviour that @edsonrm117 has.
I tested both PPP and QMI several times and it doesn’t connect.
I report the exact same behaviour even the errors.

I checked with my provider to check the APN the USER and PASSWORD and if there was some issue with my card.

I am using RPI 3B V1.2

Can i help to solve this, which further information should i report?

I have read some stuff about PAP CHAP credentials, could it be related?


Did a clean installation of Raspbian buster desktop light.
PPP seems to deliver the same type of error, cannot find a suitable secret password…
QMI is working!

I will try later to see if by trial and error with CHAP PAP i get any luck.
I have seen some replies of similar problems where PAP and CHAP helped.

Any ideas @ensar ?

Hello all,

For the Telcel Mexico, it needs and authentication type of PAP.
[Source: https://www.apnsettings.org/mexico/telcel-mx/]

For such case, you need to have /etc/ppp/pap-secrets file which contains the information as the following format

client server secret

for example
webgprs * webgprs2002
[Source: https://www.tldp.org/HOWTO/PPP-HOWTO/x1034.html]

Hello saeed

I thought authentication was missing in one file, and I add username and password to pap-secrets file. It’s not working yet, and I’m not sure I if added the Telcel authentication wrong. Here is the pap-secrets file

Then I tried with chap authentication but the message error of sudo pon still the same. Here it is chap-secrets file

Could you please confirm with the ISP if the credentials are right and the type of authentication.
Also please confirm if they need IMEIs registration over their network.

I solved authentication issues by using CHAPauthentication instead of PAP. Internet conection has not work yet. I attach results of running sudo pon command.

The ttyUSB3 is locked by the auto_reconnect service.
For the time being, you can stop it till rebooting RPi or restarting the service manually:

Managing the Auto-connect/Reconnect service:


Hi @edsonrm117 I had the same problem with a Telcel SIM card.
I don’t know why, but I solved it by installing again but without user & password option.