RPI/3B+, no qmi_wwan driver found

I’ve successfully set up my Hat and Telit LE910C4-NF using SixFab CORE, with it pinging and showing up on the dashboard all good. That said, I decided I’ rather go the QMI route. Following Setting up a data connection over QMI interface using libqmi I discover that there is no qmi_wwan driver found when I ‘lsusb -t’, nor is /dev/cdc-wdm0 present. Since the system works under CORE that indicates the hardware is installed correctly. I’ve looked to see if there’s a means to reset things to a ‘pre-CORE’ state but not found anything. My next step is to buy another module and start from scratch… and ideas? Thanks in advance for any suggestions!


You cannot use it together with Sixfab CORE; there will be conflicts. You must choose one. To uninstall CORE, use the following command:

sudo bash -c "$(curl -sN https://install.connect.sixfab.com)" -- --uninstall

Configure the module according to QMI using the command AT#USBCFG=0, as mentioned in the tutorial.

That certainly helped and solved the immediate problem. Following the tutorial, the line “sudo qmicli -d /dev/cdc-wdm0 --wda-get-data-format” executes with a valid response. However at the next line “sudo qmicli -p -d /dev/cdc-wdm0 --device-open-net=‘net-raw-ip|net-no-qos-header’ --wds-start-network=“apn=‘super’,ip-type=4” --client-no-release-cid” return with a “verbose call end reason (2,236) [Internal] call-already-present”.

Any suggestions on what to do?

This error suggests that there might already be an existing call or connection. The error code (2,236) indicates an internal issue related to the call already being present.

Use the qmicli tool or other relevant tools to check if there are existing connections. You might want to terminate any existing connections before attempting to start a new one.

sudo qmicli -d /dev/cdc-wdm0 --wds-get-current-settings

Sometimes, restarting the modem can resolve connection-related issues. You can do this by power cycling the modem or using relevant commands.

sudo qmicli -d /dev/cdc-wdm0 --wds-stop-network

After stopping the network, you can attempt to start it again.

Still no success. I powered down everything and then powered up.

I’m still getting the error “verbose call end reason (2,236) [Internal] call-already-present”.
–wda-get-data-format gets a valid return
–wds-get-current-settings returns QMI Protocol Error (15):‘OutOfCall’
–wds-stop-network returns Missing Argument for --wds-stop-network (makes me think it needs a packet data handle)
–wds-get-packet-service-status returns Connection Status: disconnected
–wds-reset claims success, but no change in behavior on any of the commands.

I’m stumped, but continuing to try and figure out how to get it to drop whatever it currently thinks is its ‘call’

Installed a fresh SixFab sim. Registered the asset as Sim Only. It turns out the earlier one was still registered as being Sim & Core Device. Thought that would fix it, but have the exact same behavior. I do see that there was a small data use for my account today, despite no CORE device being active. I have since then reinstalled CORE and power cycled the system. Same results.

Next step is to start with a fresh image for the RPI and build from there.

Any suggestions are most welcome!!!

Not reinstalled, but re-uninstalled CORE!

Well, new RPI image and now getting:
Warning ** Error reading from istream: Resource temporarily unavailable
for either of these commands:
sudo qmicli -d /dev/cdc-wdm0 --dms-get-operating-mode
sudo qmicli -d /dev/cdc-wdm0 --dms-set-operating-mode=‘online’

I’d like to get this working, but frankly am starting to shop for a different vendor, two units & two approaches all of which seem to dead end…

Can you follow the Cellular Internet Connection in ECM Mode tutorial and try connecting?

Thankfully that worked. Thanks!