QMI error message

I get this error message when trying:
sudo ./quectel-CM -s internet

pi@raspberrypi:~/files/quectel-CM $ sudo ./quectel-CM -s internet
[07-08_19:54:52:750] WCDMA&LTE_QConnectManager_Linux&Android_V1.1.45
[07-08_19:54:52:751] ./quectel-CM profile[1] = ndo///0, pincode = (null)
[07-08_19:54:52:753] Cannot find qmichannel((null)) usbnet_adapter((null)) for Quectel modules
pi@raspberrypi:~/files/quectel-CM $

I’m using the Cellular IoT HAT and Raspberry Pi 4.
The power supply is 5 V 3 A.

OS Info:

Debian 10.2
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"

I already tried plugging and unplugging the device and it seems to be powered on. The blue LED is blinking rather slow (1 sec on, very shortly off).

Make sure your shield/HAT is connected and the module is powered up.

I have the same problem, how can i make sure the module is powered up?

Check the LEDs.

According to the LEDs im in the Idle state.
Do i have to reconfigure something regarding the PPP installer?

I took 4 (Cellular IoT HAT), then 3 and ttyS0


Use the PWRKEY button.

It´s still not working i get the same error message :frowning:
I am using the power cable it is shipped with
Can it be that the device has a malfunction?

Could you please us an image of your hardware setup?

Of course, let me know if you need different angles

Did you use the USB cable sent with the product?
May I ask why you are using different USB cable?
About the confirmation of the module being powered up, you can check status LED or GPIO23 (HIGH when module is powered on).