Qmi could etablish a connection to a remote server only with eth0 first


I observed something very funny and I hope some can help me. I believe is due to 3/4G base hat, but you will te me yes or no.

I add over a Raspbery two HAT:

  1. A Pi 3/4G/LTE Base Hat from Six Base
  2. A IoT LoRa Gateway from pysupply

The first has been working only with the RAspberry
The second has been working only witht heRAspberry, as well.
Both work, but I have a funny connection issue as the following

  • I turn on the raspbbery without Ethernet cable connect and no WiFi connection
  • The Gateway hat can not etablished a connection with the remote TTN server, but I can ping a remote server and run sudo apt-get update/upgrade and installing package


  • I turn on the Reasberry with the Ethernet cable and with no WiFi configuration
  • The gateway can etablish a connection with TTN server
  • I removed the Ethernet cable and the Gazeway can still etablish the connection with the TTN Server, for sure throught wwan0, as the ethernet cable is removed. It 's still commincation since 2 hour.
  • if I reboot the raspberry without the Eternet cable connected, the Raspberry can not etablished a connection througn wwan0

In resume, the Gateway can be seen (connected to TTN), only if the Raspberry has been booted with the Ethernet cable and then removed. But if the Raspberry has been boot without the Ethernet, the communication through wwan0 is not possible.

That funny, isn’t?

Some one know, why the Raspberry “must” etablish first a eth0 connection, to make working wwan0?
Of course I would like wwan0 to be bale to work with or “without the help of eth0” :grinning:

Many thank for your help


Some one has an idea which will help me ?

Many thanks