please advice, what could be a problem on the standard config command.
I want to make communication with the Cellular IoT HAT – LTE-M & NB-IoT & eGPRS directly through UART.

thanks in advance.

Hi @dima,

Please see Quectel BG96 GNSS AT Commands Manual - Section 2.1.1

“Uartnmea” transmits data via UART3 port of the module. UART3 is connected to GPIO12, GPIO13 on Cellular IoT HAT. It is necessary to use these pins for NMEA UART.

See the Cellular IoT HAT schematic for details.

UART3 is connected to GPIO12, GPIO13 on Cellular IoT HAT. Is there a way to configure PaspberryPi to get GPS data into /dev/ttyAMA0 ?

No, there isn’t a way to do it with Cellular IoT HAT.

please explain,
is there a way to use GNSS and LTE functionality without any USB wires for Cellular LTE NB-Iot HAT


BG96 has 3 UARTs;
among them only one is used in the Cellular IoT HAT Worldwide Version(v1.1.0) and Cellular IoT Application Shield, These are at pin 8 and 10 of the HAT/Shield and can be used for AT commands.

2 UARTs are used in the Cellular IoT HAT North American Version(v1.3.0) and these are at pin [8,10] => used for AT commads & [33,32] => used for GNSS.

please explain how I can get use of UART pins?
I want to use BG96 modem without USB cord, I have Bluetooth disabled
dtoverlay=pi3-disable-bt and therefore
minicom -D /dev/ttyAMA0 -b38400 does not work. modem does not answer.

I realised that I still had USB cord plugged-in between devices, so USB2 was blockading ttyAMA0. I unplug, next reboot , made sure PWR button pressed and HAT is ON.

Wao, I was surprised I saw some response from modem in minicom on ttyAMA0.
next, I setup (install.sh for PPP daemon) for ttyAMA0. I was able to use sudo pon to connect to the internet.

but sad news I can not communicate with modem anymore, after some reboot or wrong PPP session end. I have no idea why.
I’m looking if SixFab has clear instructions on how to get the Cellular HAT working with UART ttyAMA0 without USB.

Please try to use 115200 baud rate. Also, while the module is busy for PPP via serial, you cannot use it to send AT commands.