Problem to send SMS

Hello world,

at first, I´m not a native english speaker, so please excuse if my question is not well explained.

I´m trying to send SMS with the Raspberry Pi 3G/4G&LTE Base HAT with LE910C1-EU module on a Raspberry Pi 4 with Rasbian.

I´ve tried several days to send SMS, but it failed nearly every time. Only once I get it, but I wasn´t able to repeat it. The connection to internet is working great.

What I did:
I changed wit “AT+CMGF=1” to text mode.
I had a look at the SMSC adress with “AT+CSCA?” and tried different numbers.
I tried to send with "AT+CMGS=”+4917xxxxxxx7“,145 but every time I get an error with the 331 code.
I tried with “gammu”, a small software for Raspberry Pi, there I manged to send a SMS just once, than it failed there too with the same error.

What I noticed, is that the “AT+CMGF” is allways going back to 0 (PDU mode), after I tried so send a message.

Is there something basic I didn´t undestand? I´m a liitle bit confused about the USB ports, I can access with ttyUSB2 and ttyUSB3. Is there a differents?

When I send “AT+CSMP?” command, I get : 17,173,0,0
Is this correct?

After going wild with all AT commands and a little anger, I resetet the Base Hat a couple of times with: “AT&F0”

It would be very nice if someone could help me. I hope I´m not far away from the solution. If I should give more information, please let me know.

Thank you

Hi @benedikt.m,

Error 331 means no network connection, so my suspicion falls on either:

  1. You have a bad reception in your test location.
  2. The module is not registered
  3. The module is reset

Please check the AT+CREG response and make sure it is registered before you send an SMS.
Please also check the RPi kernel log for any disconnections of the module.

You can use either ttyUSB2 or ttyUSB3. They are both used as AT ports.

Hi @ensar,

thank you for the answer and the help. Unfortunately it´s still not working.

  1. I checked a few different positions in my room, also directly to the window
  2. I send AT+CREG? and got: +CREG: 0,1, so it should be registerd?
  3. what do you mean with “The module is reset”?

I checked the RPi kernel, there was no log for any disconnection so far. I also checked the possibility to use the internet connection, it´s still working great. Only the sms commands are not working. Sometimes I also get only a “ERROR” after "AT+CMGS=”+4917xxxxxxx7“,145. Why that?

  • What is the module FW version that you use? (AT#SWPKGV)
  • Are you connected to the RPi with USB or UART?
  • Are you sure there are no reboots of the module? I’m asking because you say that CMGF returns to ‘0’ and probably this is the reason you get an error for CMGS, because you try to use it with a wrong format…
  • The FV version is:
  • I´m connected to USB.
  • No I´m not shure. To be honest, I´m not shure what I´m looking for? I opend the the RPi log with journalctl and didn´t saw any entry, wich seem´s connected to the Base HAT. Why should the module reebot? But the idea seem´s legit. How can I stop it, doing this?

Thank you!!