Pppd connection fails unless SIM card is put in phone first

Hello,

We have a number of 3G/4G&LTE Base HATs as well as Base Shields V2. This topic concerns the 3G/4G&LTE Base HAT specifically, but the issue affects both.

We are using Webbing SIM cards for a fleet of Raspberry Pi devices. We are currently piloting the Sixfab HAT and Shield V2 with these SIM cards. One thing we’ve noticed is that SIM cards do not work in the HAT or Shield if they have not previously been put into a phone. Obviously this is not ideal.

Script chat -s -v -f /etc/chatscripts/chat-connect -T wb-data finished (pid 2342), status = 0x0
Serial connection established.
using channel 13
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB3
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2f39c758> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x24 <asyncmap 0x0> <auth chap MD5> <magic 0x4eb22fb7> <pcomp> <accomp>]
No auth is possible
sent [LCP ConfRej id=0x24 <auth chap MD5>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x2f39c758> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x25 <asyncmap 0x0> <magic 0x4eb22fb7> <pcomp> <accomp>]
sent [LCP ConfAck id=0x25 <asyncmap 0x0> <magic 0x4eb22fb7> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x2f39c758]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP DiscReq id=0x26 magic=0x4eb22fb7]
rcvd [LCP EchoRep id=0x0 magic=0x4eb22fb7 2f 39 c7 58]
Modem hangup
Connection terminated.

The modem hangup is always at the same spot. If the SIM card in the HAT is one that has previously been in a phone, the connection succeeds.

Is there a step being missed in the conversation between modem and provider?

We’ve resolved this. It was an issue with the provider, not the HAT. The cards arrived locked to a provider that wasn’t available in the area they were being tested in. Putting them in a phone changed that lock, resulting in them working with the HAT.