Pi Crashing when UPS Shield Attached


i have a Pi 3B running latest Raspberry OS (as of 2020-06-15) and the UPS Power Shield. I have previously tested this shield on this pi, though with an older raspbian, and don’t recall any issues. Today i reinstalled everything from the ground up.

I installed the Power Software and attached it to the cloud, everything seemed ok. However, now if I have the UPS Shield attached the Pi boots, the login prompt comes and then the pi crashes

Seemed simillar to this post: A little excited? - SSL Error on download
as I don’t have any network connectivity at this point; However plugging the LAN cable in doesn’t seem to help. I have now uinstalled the Power Software, but the problem still exists, If i remove the UPS Shield, then the Pi works as expected.

any thoughts?


Could you please share the image of your setup and a screenshot of the dashboard?

HI @ensar - I think I may have solved the issue after some debugging. Here is the full story and my conclusions.

I pre-ordered the UPS Shield, and assembled it when i got it, might have powered it up once, but largely didn’t use it as I ran out of time and it sat on the shelf until a few days ago. So at this stage it had the factory firmware (according to my notebook it arrived to me on April 28th - the only marking i see on the board is v1.0.0). Again, looking back at my notes, on the 30th my 18650 battery arrived and it powered up straight away - no other notes, so I didn’t really do much with it.

A few days ago, i got the time to work with it properly; so I set up a brand new Raspberry Pi Lite OS (kernel 4.19.118) and installed the Power Software - I don’t believe I had the 18650 battery installed. It connected to the Cloud, and looked ok. I updated the firmware, played around a bit, then shutdown, removed the shield and started working on my 4G board.

Later in the day, I added the shield back, and added the battery - then it would boot and a few seconds later crash. I registered the above post.

I have since debugged, and it now appears to be stable. What I did was put the battery back, and let it charge to full and it worked. Reading the documents and cross-checking my notes, what i think it happening is perhaps a bug(?) in the firmware - maybe its the latest firmware or i was lucky the first time i powered up. So when it started crashing I believe my battery was <5% and so it was shutting down as per design. so when the battery was charged it was ok. Makes sense (though if i have mains power in, that should override the low battery?)

now in some testing - it seems the shield “remembers” the last battery state - so if the battery is not present, it just looks at the previous state. I tested this by running without the battery, and L2 was still solid green and it didn’t shutdown. But if i have the battery in and its <5% then the pi shutsdown; if i take the battery out, its still shutsdown.

Just a theory - but once the battery is charged I can run with or without the battery and just powered by the USB

@ensar given my system appears stable, I will close this issue with my last post as solution - but would love to hear back on what you guys think of my conclusion!