Pi Cellular IoT HAT-Auto reconnect doesnt work!


I followed the tutorials for PPP configurations for Pi Cellular IoT HAT and did the auto reconnect. It worked fine the first time and the internet was working fine.

When I rebooted, only power light came on, no status and netlight. I pressed the powerkey and then status and netlight came on, but no internet. Tried it a few more times with no luck. I am using the Twilo sim. Can anyone help please, we have to deploy our device in the field next week.

I was able to make it connect to the internet. It still doesnt auto connect if do a soft reboot or powercycle untill I run “sudo pon”

Hi @skhaderk,

Did you check the status of the reconnect service? This reconnect service is based on the systemd.

What is the output of sudo systemctl status reconnect.service

First, check if the wiring-pi is working correctly.
Simply run:
gpio readall

If it return any error, the issue is with the wiring-pi package.
This can be fixed by

  • cd /tmp
  • wget https://project-downloads.drogon.net/wiringpi-latest.deb
  • sudo dpkg -i wiringpi-latest.deb