No wwan0 on ME910C1 after SixFabCore configuration

I tried following the quick start for the LTE-M module on a Pi 4b with the latest 64 bit OS, but it doesn’t appear to work.

If I unplug the modem and run the installer, I get a message saying “[Warning] The operating system is not one of the supported ones…”. I then hit ‘y’ to continue. The installation seems to mostly work, the installer seems to hang at 100%.

Then, I plug the USB back in and hit enter to reboot. After a reboot, I am able to see the modem on the dashboard, but it seems that Wifi is the only available interface. I don’t see wwan0 listed. I can do AT commands and if I do a AT+CGREG?, I get +CGREG: 0,2.

How to I finish the installation or get the installer fully working?

I just tired the same process using the LE910C4-NF and the modem seems to be recognized correctly. So, I don’t think there is a problem with my Pi version or the SixFabCore tool. However, the ME910C1-WW doesn’t seem to be set up correctly.


We recommend that you install CORE by running the same installation code on 32-bit OS to avoid potential problems.

Okay, I will try a 32 bit image to see if it works better.

Now that I have switched to the 32 bit image it looks like it is able to sometimes detect the modem. At one point, it said the signal strength was excellent, but the LTE type was GSM. A few seconds later, the signal dropped out again. I have the standard LTE model in the same location and it seems to work fine with an excellent connection. It also lists the fixed incident count with a value of 4.

Could you help me figure out if this is an antenna/connection issue or configuration/setup issue? AT+CSQ is returning 99,99

+CSQ: 0,99 indicates you have very weak signal strength. There is an antenna/connection issue. Please make sure your antenna is connected properly. Signal reception is a critical issue for the LTE-M module.

It seems like it might not be an antenna problem, but I am not sure. I tried a different antenna and double-checked that the connections. I was finally able to connect wwan0 to T-Moble (GSM) and the signal strength was excellent +CSQ: 21,7. I then tried a ping to and it seemed to work, but was really slow. I also noticed at one point the network switched to AT&T(Cat M1) and the signal strength was still excellent. However, it disconnected and switched back to GSM after a few minutes.

This is what I get for ifconfig when connected to GSM after a ping:
wwan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::828b:fe66:dd71:be51 prefixlen 64 scopeid 0x20
ether 00:a0:c6:30:7d:50 txqueuelen 1000 (Ethernet)
RX packets 45 bytes 10475 (10.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 93 bytes 9993 (9.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Should I expect better performance? I am in the city and have excellent LTE coverage to T-Mobile. Should I be able to connect via LTE-M? Would it be worth contacting Verizon to try to get a sim for their network?

Is there something else wrong?

I continued to experiment with this over the weekend and have not been able to get a LTE-M connection. It is continually dropping back to GSM. I even tried 30 miles across town (still in the city) and it still didn’t connect to LTE. It is almost like the T-Mobile and AT&T towers in my area aren’t accepting a LTE-M connection.

Should I consider ordering a different antenna (using the antenna from the LTE-M kit)? Is there something that needs to be configured for the carriers to allow LTE-M?

If I switch to the LE910CF-NF in the same location, things work great.

You can try to force LTE-M with the AT#WS46 command.

They will give you better information if you consult the carriers with the LTE-M coverage for your area.

I was going to reset the modem and try this experiment using a different Pi board. However, now the modem seems to be unresponsive. I get the following from the firmware update tool

If I plug it into the Pi, I don’t get anything under /dev/ttyUSB*

Is there a way to bring the modem back to life?

It looks like the ME910C1 is stuck in a bootloader mode. Is it bricked?

Screen Shot 2022-07-06 at 3.58.55 PM

Can I get a refund or replacement on my ME910C1 modem? It never seemed to work and now it is seemingly bricked. I don’t think I abused it in any way, I was just troubleshooting it because it wouldn’t connect to any towers in my area.

I have since ordered 2 other LTE modems that work great. Ideally, however, I want to use a LTE-M model for this project.

We’re really sorry to hear that it didn’t fulfill your expectations. Please email to with your order number and our team will contact you right away.

If you have any further questions or comments, please reach out so I can assist you further.
Thank you for understanding.

The exchange is in progress. I will try agent when the new module arrives.