No longer able to connect

I had this setup working a couple of weeks ago, now when I tried to use it, I am not getting a cell network connection.

3G/4G-LTE HAT with a Quectel EC25-A modem.
SixFab SIM.

I am not able to ping an ip address using: ping -I usb0

The output of “AT+CREG?” is:
+CREG: 2,5,"BB84","1C89F0C",7
(I think this should be “0,5” (NOT 2,5))
Does this indicate that it’s not registered??

The output of “AT+CGCONTRDP” is:
+CGCONTRDP: 1,5,super,,,,

What else can I provide to troubleshoot this issue?

NOTE: I do NOT have the CORE software installed.

From a clean boot (everything comes up, like it should) I can’t ping anything via usb0.
ping -I usb0 or ping -I usb0
BUT, if I connect to the Quectel modem via minicom and do a reboot AT+CFUN=1,1, after a few moments when the modem comes back up, pings are successful! Both to an IP address and to a domain name.
It’s almost as if the modem services are starting too soon, before the rest of the OS is fully up, maybe??
Is there a way to have that service wait a bit, or maybe I can script something to send a reboot after the OS is fully loaded.
NOTE: I am running Ubuntu 20.04.6 LTS on a FriendlyElec NanoPi-R1

Well, it appears that a reboot of the modem no long clears the problem up.
Nothing I have tried today will get me connected via the SixFab SIM.

Do you have any ideas that can help me get this working?
Is there something on your end blocking my connection?
I have a credit balance of about $15.00 (and I think that should be set as PAYG.)

Hi @ScottV ,

Thank you for the details regarding the issue and the updated information.

Your registration state is “5,” indicating that you are registered on the roaming network.

You also have the IP address.

Your Sixfab SIM is active, and nothing is affecting your connection. Do you have any services on your operating system that are related to any network, which might be preventing the modem from accessing the internet? For example, services like ModemManager and NetworkManager could potentially be interfering with your configurations.

I stopped / disabled ModemManager and that seems to have improved things.
I need to do more testing to see if that totally solved the issue.