ModuleNotFoundError: No module named 'RPi'

I don’t know how python works.

I install library like that:

git clone
cd Sixfab_RPi_CellularIoT_Library
sudo python3 install


sudo pip3 install sixfab-cellulariot

I created a python file for relay:

from cellulariot import cellulariot
import time

node = cellulariot.CellularIoTApp()



But when I tried:

I have this error:

Traceback (most recent call last):
  File "", line 1, in <module>
    from cellulariot import cellulariot
  File "/usr/local/lib/python3.7/dist-packages/sixfab_cellulariot-1.2.0-py3.7.egg/cellulariot/", line 11, in <module>
ModuleNotFoundError: No module named 'RPi'

Where is my error?

First part solve, thanks to my friend Carmelo.

pip3 install RPi.GPIO
pip3 install smbus


Sixfab Raspberry Pi Cellular IoT Application Shield Class initialized!
Traceback (most recent call last):
  File "", line 7, in <module>
  File "/usr/local/lib/python3.7/dist-packages/sixfab_cellulariot-1.2.0-py3.7.egg/cellulariot/", line 756, in turnOnRelay
RuntimeError: Please set pin numbering mode using GPIO.setmode(GPIO.BOARD) or GPIO.setmode(GPIO.BCM)
/usr/local/lib/python3.7/dist-packages/sixfab_cellulariot-1.2.0-py3.7.egg/cellulariot/ RuntimeWarning: No channels have been set up yet - nothing to clean up!  Try cleaning up at the end of your program instead!

Hi @fred,
This library is only available for Cellular IoT HAT and Cellular IoT Application Shields.

Sorry, mistake, I have raspberry-pi-cellular-iot-application-shield .

When I try sample

Sixfab Raspberry Pi Cellular IoT Application Shield Class initialized!
BG96 module disabled!
BG96 module enabled!
Traceback (most recent call last):
  File "", line 18, in <module>
    print("Acceleration: "+str(node.readAccel()))
  File "/usr/local/lib/python3.7/dist-packages/sixfab_cellulariot-1.2.0-py3.7.egg/cellulariot/", line 724, in readAccel
  File "/usr/local/lib/python3.7/dist-packages/sixfab_cellulariot-1.2.0-py3.7.egg/cellulariot/", line 33, in __init__
FileNotFoundError: [Errno 2] No such file or directory

Okay. Please check if I2C is enabled.
Enable serial_hw and I2C interfaces by following instructions below:

  1. Run sudo raspi-config
  2. Select 5 Interfacing Options
  3. Enable P5 I2C
  4. For P6 Serial
    • Disable Login shell to be accessible over serial
    • Enable Serial port hardware
  5. Finish
  6. Reboot

Yeeeeeeah! It’s works!

In docs, there is P6 serial settings advice, but not P5 I2C.

Thanks a lot! :star_struck: :hugs:

I have other questions. I will open other thread.
Thanks again

1 Like

Just to add some info. I tried all the above. What worked for me was to comment this line from /boot/config.txt