Minicom: cannot open /dev/ttyUSB1: No such file or directory

If I run lsusb I see Bus 001 Device 021: ID 1bc7:1205 Telit Wireless Solutions

At first when I ran minicom -D /dev/ttyUSB2 -b 115200 it worked, but I was trying to set the APN using as the value in place of super, but it was returning an error.

Then I regrettably typed AT#USBCFG=3, it returned OK and then did not reconnect.

Now, although I see the device in lsusb, the command sudo minicom -b 115200 -D /dev/ttyUSB2 does not work and there is no /dev/ttyUSB* file of any kind.

Can someone advise me on how to reconnect, or is there a way to hard reset the device?

edit: when I connect the USB cable, the /dev/cdc-wdm0 appears, however using minicom in the same way as /dev/ttyUSB2 doesn’t work

I did the same thing, and solved it with Windows.

Telit has drivers and software for connecting to the modem for windows that you can download from them directly. EVK/EVB Drivers - Telit

I used the WHQL drivers and the AT Controller from that page. You’ll be able to issue AT commands with that software, and you can do AT#USBCFG=0 to get it back to the default state.

1 Like

ah well that’s a relief to hear :slight_smile: did you plug your device into your windows box without the raspberry pi then? I will have to test it out when I get back home!

I left the hat plugged into the pi for power, but connected the USB to the windows box. Worked great.

solved here on linux