ME910C1-WW not detecting SIM card

I just received a Raspberry Pi 4G LTE HAT with a Telit ME910C1-WW modem. When following the steps to set up Ethernet Control Module and setting the APN, it returned a +CME ERROR: 10 (no SIM detected), as you can see in the screenshot below:

Everything on the hardware side looks okay, no bent pins on the SIM module and the SIM card looks to be seated correctly. I tried doing a firmware update on Windows and while that was successful, the reported firmware version is still the same.

When plugging the HAT over USB into both a Windows computer and the Ubuntu VM on my laptop, both network managers on both operating systems are reporting that I need to insert a SIM even though the SIM is very much inserted as you can see in the photo below.


What gives? Is my modem possibly faulty? This was happening before the firmware update as well, giving off the same +CME ERROR: 10 when attempting to set the APN.

I should also mention that I am using the Sixfab SIM card, but when attempting to insert an old Verizon SIM card I had lying around, it was still reporting that a SIM was not being detected.


Can you share the AT+CPIN?, AT#QSS? and AT#SIMDET? commands output and also a close-up photo of the SIM card slot?

I would love to give you the output of those commands…but this morning the modem isn’t even showing up in lsusb even though the HAT is connected over USB. /dev/ttyUSB isn’t showing up either. It’s also not showing up when plugged into my Mac either - VMWare Fusion isn’t offering to connect the modem to Linux (it was doing it last night).

Here’s a closeup photo of the SIM pins.

Just an update - I haven’t been able to test if the modem is still not showing up over USB in the past few days, but I’ll give it a shot tonight to see if it’s still having issues.

Nonetheless, if it turns out this modem isn’t working, what are the chances that I could send this modem back and exchange it for a different modem like the Telit LE910 or the Quectel EG25 (and pay any price difference)?

The modem still isn’t being detected unfortunately. Here’s a screenshot from lsusb.

Not too sure where to go from here :confused:

Can you share the following command outputs:

dmesg | grep tty
cat /etc/os-release

Ok! So it looks like I needed to reseat the modem in the PCIe card and it’s showing up over USB again. These are the output of the commands from earlier:

I will follow up if the modem is able to get online.

Looks like the modem is online and able to transmit a signal! It seems like cleaning the pins off of the modem with a microfiber cloth was able to get things workings again.

1 Like