LTE does not work very well


I have been tethering my home lab from my Samsung Galaxy S9 with easytether. This has worked surprisingly perfect. I have my samsung plugged into an Rpi2 which relays the internet over ethernet to a switch. I wanted to remove the phone from the equation by getting the Pi Hat. The connection is so much less reliable. I have to restart it like every 10 minutes.

At first I tried to follow the tutorials, but they all were slightly wrong with the current version of raspbian on the Rpi 4. They worked but the connection was always shit. Now Im asking for some reference that shows that they work at the specifications they are listed for. Has anyone setup this product to work? Can you share some details?

Can I please get some support for this product?

Hi @channon,

Could you provide better information about your setup? Which hardware and antennas are you using? Pictures? Log files? What ISP, network, etc?

What do you mean by ‘slightly wrong’? Is it because you are using a different version?

I have my own setup and working, so yes, it does… How are your antennas mounted, oriented? Sometimes a 90° change in the orientation can help a little. Have you tried the setup outside? Have you tried a stronger antenna?

How are the cables run? Have you considered sources of electronic noise such as the Rpi, itself, or any poorly shielded power supplies?

Consider the fact that most of the people helping on this community forum are others, like yourself, who wish for a polite and constructive discourse. We may not work for sixfab, and by the tone you started with, I can see why they are reticent to assist you. More bees with honey than with vinegar and all that. If you want help direct from the company, maybe email them? :::steps down from soap box:::

So, please provide us with a little more to go on and we might be able to assist you and offer constructive advise. :upside_down_face:


My setup is as follows:

  1. Raspbian (August 20th 2020 release)
  2. Raspberry Pi 4 (4gb)
  3. EC25-A
  4. Raspberry Pi 3G/4G & LTE Base HAT

First I followed this tutorial: There is a problem with the dhcp as other users have mentioned in this forum.

Something like this I guess
'denyinterfaces wwan0' >> /etc/dhcpcd.conf

Okay this works and my speed is okay but it just stops randomly and the interface reports many frame errors (>1%).

So I switched to this tutorial

Similar issues with dhcp but mostly works by following the guide. The autoconnect doesnt work as linked but that is okay with me – for temp I added a connect script to the cron table.

No more frame errors which is nice but the connection randomly breaks, no dns lookups work and generally it needs to be rebooted to fix.

I have tried both Verizon and AT&T with these products and have the same results. As I mentioned previously Id like to use this as some kind of router. So I followed the wifi hotspot tutorial and that did not work. I was able to set it up manually but the RaspAP approach just does not work at all (the workaround is okay though:

sudo apt install hostapd -y
sudo systemctl unmask hostapd
sudo systemctl enable hostapd
sudo apt install dnsmasq
sudo DEBIAN_FRONTEND=noninteractive apt install -y netfilter-persistent iptables-persistent


# doesnt work need to copy pasta (and use full file)

interface wlan0
static ip_address=
    nohook wpa_supplicant

  >>  /etc/dhcpcd.conf

>>  /etc/sysctl.d/routed-ap.conf


sudo iptables -t nat -A POSTROUTING -o wwan0 -j MASQUERADE
sudo netfilter-persistent save


interface=wlan0 # Listening interface
# Pool of IP addresses served via DHCP
domain=wlan     # Local wireless DNS domain
# Alias for this router

>> /etc/dnsmasq.conf


sudo rfkill unblock wlan




>> /etc/hostapd/hostapd.conf


sudo reboot

## can connect with ssh pi@ or ssh pi@gw.wlan

I do realize that I am on the community page but this forum is hosted by sixfab and they should support their users. Or at least reach out for a private dialog.

Hi @channon,

Have you tried using ECM mode?

Or, you might get some ideas here. I haven’t tried it (since I haven’t needed it), but I may try the MBIM mode for the increased speed.



So far this seems work better then the previous guides. I really thank you for your help @shawnj007. I was so frustrated with getting this to work and now it seems stable for the most part :slight_smile:

1 Like