Interface name changes with each reboot

Is there a way to ensure that the USB connected HAT comes up each time as “usb0”?
As it sits now, each time my device reboots the interface comes up with a different/unique name.
I am running in “ECM” mode.
This behavior is noticed when I have the HAT connected via a USB cable to a laptop/desktop PC running Ubuntu 20.xx+
(Note: I have a Ubuntu device running 16.x something and I see the interface as usb0, as I should.)
I think I could (via /etc/network/interfaces or in NetPlan) “nail down” the interface name to usb0, but the MAC address comes up randomized after each reboot.
So, is there a way to stop the MAC for randomization?


Disable the “Predictable Network Interface Device Names” setting. For more details, please refer to the documentation: PredictableNetworkInterfaceNames