How do i properly turn off Sixfab wwan0

Hi All,

I have tried the following commands with the Sixfab Hat installed on a RaspberryPi 4B+ in the standard way. Everything seems to be working fine. However when I attempt to turn off the wwan0 interface added during the installation by issuing either of the following commands, the interface goes does for 30s-1 min and then restarts:

sudo ifconfig wwan0 down
sudo ip link set wwan0 down

Inspecting the network interface, I see the traffic turn off and then it goes back online, with the ip link command, I confirm the interface disappears and then reappears. I am assuming there is some service running in the background that was installed, but I cant find docs on this anywhere. Can someone please assist?

My setup has both wifi and cell set up and i have a preference on wifi. When both interfaces are on however I get some residual utilization on the cell net.

Thanks in advance for the help.



It seems like there might be a background process or service that’s managing the wwan0 interface and causing it to restart after you manually bring it down.
Can you check the modem / network manager or Sixfab CORE(core_manager) services?

I checked that and explicitly killed the service with systemctl . The service rebooted on its own. In my free time I was going to go through the code you guys have for installation to figure out what it’s doing, will report back what the situation is.

Disable Auto-Restart. Some services are configured to automatically restart interfaces if they go down. You might need to disable this behavior. Look for configuration files or service settings that control this behavior and modify them to prevent automatic restarts.

Hi @ensar ! I’m having the same issue with the hat. Upon looking into the background process, I found that it’s sixfab’s

own software that restarts the service. How can I disable this? Thanks

Hi @steadz12 ,

You can disable it with the command systemctl disable core_manager. After running it, remember that Sixfab CORE will be disabled.

So here is a use case where sixfab fails with the core manager on. I turned off the sim in and my connection is bricked unless I reset the network settings.

And to do that I need to turn off the service otherwise it will overwrite the existing settings. It seems the best thing to do here is the following:

1- either set the metric priority much higher not 204
2- turn off automatic overwriting of network settings
3- turn off as you suggested core_manager but then the entire interface at will no longer be functional…

Can you guys advise?