GPS never getting a fix

I am starting to dig into all the components of this shield. The GPS appears to be working, but never receives a fix.

When using the GPS python script from the tutorial, I continuously get the following:

No satellite data available.

I have also tried using the cellulariot python package too from your Git repo with the following code:

from cellulariot import cellulariot
node = cellulariot.CellularIoTApp()

I receive the following response:

I have tried both the provided GPS/LTE antenna and an active antenna. I have tried moving the device to the window and even left it in the backyard for a few hours with a big battery pack, but never received a fix. I tested the antennas with an Adafruit Ultimate GPS and was able to get a fix with both antennas within a minute, even indoors by the window.

What further steps can I take to diagnose the issue?


Any help here or am I returning it as a defective unit?


Did you solder the SJx jumper before using the Active antenna?
What is the Firmware of the module?
AT+QGMR will give you the Firmware details.

Thanks. I did find the SJx jumper info in the FAQ. After soldering, the active antenna works. I am still a little surprised the passive antenna did not work.

I would suggest putting a sentence in the GNSS tutorial mentioning this jumper for active antennas, as it is apparently easy to miss in the FAQ. :sweat:

Thank you for your feedback.
We will add it to the tutorial.