GET IMEI & SIM info from sixfab 4g/lte hat with UART enabled

How can I use shell or python to get my IMEI & SIM info from the 4g/lte hat on a raspberry pi when I’m using ppp via UART?

Hi @gcrow,
Send the following AT commands with minicom:
AT+GSN Request International Mobile Equipment Identity (IMEI)
AT+CIMI Request International Mobile Subscriber Identity (IMSI)
AT+CGSN Request Product Serial Number Identification

See more AT Commands Manual - 5. (U) SIM Related Commands

Will installing minicom cause any issues with the other software that I have for PPP?

Well – i installed minicom - it worked to bring up the AT commands. After I went out of the minicom terminal to try to automate it - now my sudo pon command fails. I uninstalled minicom (thinking that wast the only change) but that didn’t work either - so now I can’t even get sudo pon to work. Any ideas? I reinstalled the ppp link: wget
and that didn’t help either.pi@raspberrypi:~ $ sudo pon
pppd options in effect:
debug # (from /etc/ppp/peers/provider)
updetach # (from /etc/ppp/peers/provider)
dump # (from /etc/ppp/peers/provider)
noauth # (from /etc/ppp/peers/provider)
remotename 3gppp # (from /etc/ppp/peers/provider)
/dev/ttyAMA0 # (from /etc/ppp/peers/provider)
115200 # (from /etc/ppp/peers/provider)
lock # (from /etc/ppp/peers/provider)
connect chat -s -v -f /etc/chatscripts/chat-connect -T vzwinternet # (from /etc/ppp/peers/provider)
disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
nocrtscts # (from /etc/ppp/peers/provider)
modem # (from /etc/ppp/peers/provider)
asyncmap 0 # (from /etc/ppp/options)
lcp-echo-failure 4 # (from /etc/ppp/options)
lcp-echo-interval 30 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/peers/provider)
novj # (from /etc/ppp/peers/provider)
novjccomp # (from /etc/ppp/peers/provider)
ipcp-accept-local # (from /etc/ppp/peers/provider)
ipcp-accept-remote # (from /etc/ppp/peers/provider)
ipparam 3gppp # (from /etc/ppp/peers/provider)
noipdefault # (from /etc/ppp/peers/provider)
ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
defaultroute # (from /etc/ppp/peers/provider)
usepeerdns # (from /etc/ppp/peers/provider)
noccp # (from /etc/ppp/peers/provider)
noipx # (from /etc/ppp/options)
abort on (BUSY)
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (ERROR)
abort on (NO ANSWER)
timeout set to 30 seconds
send (AT^M)
expect (OK)
Script chat -s -v -f /etc/chatscripts/chat-connect -T vzwinternet finished (pid 524), status = 0x3
Connect script failed

The port is locked because you are using the same port when PPP connection and sending AT commands.

Nope - I had uninstalled minicom, rebooted and then only focused on the sudo pon …Still wasn’t/isn’t working

I removed the modem. powered off pi…waited 5 mins…then reinserted it, powered up and it works now

I still can’t get a script to get the IMEI and SIM out of the hat/modem

Got it - wrote a minicom script