[ERR] Timeout, couldn't get response on TELIT LE910C4-EU

Hello, I’ve got a Raspberry 3b with a TELIT HAT which used to work until last weekend. I thought it may be a SDK I compiled so:

  • I have gone back, cut a new SDXC card with a vanilla Raspian Bullseye,
  • (Un)plugged each cable at least twice,
  • swapped the HAT to another Raspberry for same result and back.

In short, I am stuck. The device exists, but it isn’t responding.
admin@sonia:~ $ lsusb
Bus 001 Device 004: ID 1bc7:1206 Telit Wireless Solutions LE910C4-EU
Bus 001 Device 003: ID 0424:ec00 Microchip Technology, Inc. (formerly SMSC) SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Microchip Technology, Inc. (formerly SMSC) SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

admin@sonia:~ $ atcom AT
[ERR] Timeout, couldn’t get response

Takes 10 seconds and times out. minicom freezes on attempt.

The wwan0 adapter has an IP and seems in working order, but has no connection:
wwan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::fdab:2759:50e:cfe7 prefixlen 64 scopeid 0x20
ether e6:0c:62:f0:c6:c5 txqueuelen 1000 (Ethernet)
RX packets 216 bytes 13175 (12.8 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 343 bytes 27100 (26.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

The SIM shows no connection to the network, even there is plenty of coverage (-66dBm) where it’s at. I have a bad feeling this could be a hardware issue. How to check?

Remote support is enabled and token available.

Thanks a lot


Is your device active? If so, could you PM me your remote-support token so that I can check and solve it?

Thanks for sharing!

This port is busy because the CORE service uses the modem’s ttyUSB2 port. For this reason, when sending AT commands with atcom, commands can be sent from available ports with the --port parameter.

$ atcom AT+CSQ --port /dev/ttyUSB4
+CSQ: 99,99
$ atcom AT+CREG? --port /dev/ttyUSB4
+CREG: 0,0
$ atcom AT+CGREG? --port /dev/ttyUSB4
+CGREG: 0,0

Signal strength is unknown or cannot be detected. So it indicates that you are not registered on the network. Make sure your antenna is connected properly.

Hi, not sure how your response is meant to help me.
I installed with the installation script, no customizing or editing. It worked in July.
It stopped when I tried to activate the GNSS. So I wiped the Raspi, reinstalled everything and since the HAT is not working anymore for me.

Both antennas are attached and my reception level (measured next to the HAT) is -65dBm on 4G LTE.

When I tried to run your commands /dev/ttyUSB0 has timeout, the remainder USB1-4 call OSError: [Errno 71] Protocol error

jj@lara:~ $ atcom AT+CREG? --port /dev/ttyUSB0
[ERR] Timeout, couldn’t get response
jj@lara:~ $ atcom AT+CREG? --port /dev/ttyUSB1
Traceback (most recent call last):
File “/usr/local/bin/atcom”, line 8, in
File “/usr/lib/python3/dist-packages/click/core.py”, line 829, in call
return self.main(*args, **kwargs)
File “/usr/lib/python3/dist-packages/click/core.py”, line 782, in main
rv = self.invoke(ctx)
File “/usr/lib/python3/dist-packages/click/core.py”, line 1066, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib/python3/dist-packages/click/core.py”, line 610, in invoke
return callback(*args, **kwargs)
File “/usr/local/lib/python3.9/dist-packages/atcom/cli.py”, line 215, in handler
at = ATCom(
File “/usr/local/lib/python3.9/dist-packages/atcom/cli.py”, line 48, in init
self.serial = serial.Serial(port, baudrate, rtscts=rts_cts, dsrdtr=dsr_dtr)
File “/usr/lib/python3/dist-packages/serial/serialutil.py”, line 244, in init
File “/usr/lib/python3/dist-packages/serial/serialposix.py”, line 343, in open
File “/usr/lib/python3/dist-packages/serial/serialposix.py”, line 691, in _update_dtr_state
fcntl.ioctl(self.fd, TIOCMBIS, TIOCM_DTR_str)
OSError: [Errno 71] Protocol error