Device ttyS0 is locked

When I use the sudo pon command I get this output.

pppd options in effect:
debug # (from /etc/ppp/peers/provider)
updetach # (from /etc/ppp/peers/provider)
dump # (from /etc/ppp/peers/provider)
noauth # (from /etc/ppp/peers/provider)
remotename 3gppp # (from /etc/ppp/peers/provider)
/dev/ttyS0 # (from /etc/ppp/peers/provider)
115200 # (from /etc/ppp/peers/provider)
lock # (from /etc/ppp/peers/provider)
connect chat -s -v -f /etc/chatscripts/chat-connect -T fast.t-mobile.com # (from /etc/ppp/peers/provider)
disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
nocrtscts # (from /etc/ppp/peers/provider)
modem # (from /etc/ppp/peers/provider)
asyncmap 0 # (from /etc/ppp/options)
lcp-echo-failure 4 # (from /etc/ppp/options)
lcp-echo-interval 30 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/peers/provider)
novj # (from /etc/ppp/peers/provider)
novjccomp # (from /etc/ppp/peers/provider)
ipcp-accept-local # (from /etc/ppp/peers/provider)
ipcp-accept-remote # (from /etc/ppp/peers/provider)
ipparam 3gppp # (from /etc/ppp/peers/provider)
noipdefault # (from /etc/ppp/peers/provider)
ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
defaultroute # (from /etc/ppp/peers/provider)
usepeerdns # (from /etc/ppp/peers/provider)
noccp # (from /etc/ppp/peers/provider)
noipx # (from /etc/ppp/options)
Device ttyS0 is locked by pid 2855

How do I get the ttys0 device to be unlocked thanks.

Do you have enabled the Serial port hardware and disabled login shell over serial?
It looks like ttys0 is being used by other services. You are getting this error because it is busy.

Hello,

I do have the same issue.

  • Fresh install of Rasberry
  • I have enabled the Serial port hardware and disabled login shell over serial.
  • Did the SW install as described in the docs
  • get the error Device ttyS0 is locked by pid in sudo pon

Any other suggestion?

Hi @bart-9287,

You might have installed the reconnect service. For the time being, you can stop it till rebooting RPi or restarting the service manually: sudo systemctl stop reconnect.service

Now try sudo pon

Check, that gave me some more options, thanx
going to continue to setup

Bart

Sorry, no modem seen with modem manager

sudo mmcli -L
No modems were found

Bart