Data Usage Not Updating

Hello, I recently set up my Raspberry Pi cellular kit and successfully have LTE data on the device, and the ability to connect to it with other devices.

Potential Issue:
On the Sixfab Connect website my Total Data Usage and SIM stats show zero MB used. It has been several days now with no change.

I know I have used 25 MB of data as the Data Packages screen shows I have 475 out of 500 MB remaining on my data package.

Is there a setting I need to change on the modem for the Sixfab Connect website to be able to show me my up to date data usage?

Thanks!

Hi,

Thanks for reaching out.
We’re working to get this fixed as soon as we can. Our team is jumping on that problem right away, and I will let you know as soon as it’s fixed.

1 Like

@ensar Thanks for looking into it. In case it is relevant, my modem is set up this way:

wwan0 is the active interface

However, wlan0 is first on the list

Should I move wwan0 up to the top? Would this fix the data logging problem?

I tried assigning wwan0 to the #1 priority slot but the modem thinks it’s already there:

So, it looks like my idea from my previous post doesn’t have anything to do with the data usage not logging issue.

This issue is caused by our side. I’ll let you know when it’s fixed.

1 Like

Thanks for the fix. My data usage graphs now show bars and statistics. :+1:

Just wondering if the stats are not updating again—on my dashboard after using the SIM for a bit yesterday, I see “40.42 MB Data Usage”, but if I go to the SIM details and the Stats page, I see a lot of 0.00 in every column and no usage in the graph. I also see zeroes on the ‘Total Data Usage’ page under Usage.

Hello, my stats and graphs are working. I’ve noticed they update at the end of the hour, so it takes up to 60 minutes for used data to appear and be counted. Also, the current time is on the last page of data, so you may have to scroll through pages to the right see the new stuff. You could be seeing a bunch of zeros because your device was off three days ago. If your system is not tallying data at all, I’m sure @ensar can hook you up.

Spoke too soon. My graph and data table are blank again under “Total Data Usage.”

I’m seeing (or rather not seeing) the same things.

Dear @ensar

No data shows in my graph or table under “Total Data Usage”, but I can log into my individual SIM and there are usage data under “Stats.” Is there a way to make it show up in both places? Getting to “Total Data Usage” takes a lot fewer clicks. Thanks!

This still seems to be an issue… it makes me a little anxious because I’m going to be running an experiment which could use up a lot of data, but I am monitoring the data usage on my own.

It would be nice to make sure the data in the system matches up to my own measurements so I don’t get a surprise bill.

For some reason the only number I see at all now is on the Dashboard page, and it hasn’t updated in a day.

My apologies for the delayed response. Well, it sure took me a while, but we have made progress on this issue.

You can now view your data in the “Total Data Usage” table. In addition, statistics on SIM details are updated according to your data usage.

You can be assured that you will not be charged for data you have not used in the past. Please don’t ever hesitate to contact us no matter what your concern is.

We thank you and appreciate your patience while we worked to fix this issue.

1 Like