Connection problem, Lithuania


I use three Pico LTE for small IoT project. Since aprox. 12am yesterday its all stopped connecting to the network. Previously successfully connected to Tele2 LT. Balance and remains of data is ok. I can’t figure out what’s wrong. Device UUIDs: d09e621f571b4332abb888efef19e848, 6361491c2f994c45b7b2d03defe0a6a3, a4674b282ebf4a35b0062a5f34f17649. Please help solve this problem.

Regards, Alexey


The AT commands on the troubleshooting page can help you identify the cause of the connection problem. Additionally, I have reset the connection on all three of your devices. Resetting your SIM’s network connectivity may solve general connectivity issues. The reset will terminate any active data session and force the SIM to re-attach to an available network.

Hi, today I resolved a similar problem by sending the AT command “AT&F” to reset the modem, and after that, it worked again.


I try send AT command “AT+COPS=?” on to one of devices - it’s hangs. When i change network scan mode to “GSM only” (AT+QCFG=“nwscanmode”,1,1) it found three networks and successfuly connected to one of it ((1,“Tele2 LT”,“Tele2 LT”,“24603”,0),(1,“LT BITE GSM”,“BITE”,“24602”,0),(1,“Telia LT”,“Telia”,“24601”,0)). Is it a problem with LTE in Lithuania or something wrong with the modem settings?

Thank You for advice

I’m not an expert; now I’m learning to teach this to my high school students next year. After tinkering (trying other MicroPython versions, etc.) with the board, sometimes the modem connected to the network didn’t respond to AT commands or send messages. I nuked the flash memory in the Pico W with the nuke file and reinstalled everything from scratch. I also deactivated and activated the SIM from the web management account, then let the modem sit for a few minutes to start up and register to the network. Maybe it will work for you.

Problem solved with AT+QCFG=“band”,0xF,0x80084,0x80084