Cellular IoT Shield with Hologram Sim not connecting via PPP

I am using the hologram SIM card but I cannot establish a connection this is the code after I give the command sudo pon:

**pi@dronepi** : **~ $** sudo pon

pppd options in effect:

debug # (from /etc/ppp/peers/provider)

updetach # (from /etc/ppp/peers/provider)

persist # (from /etc/ppp/peers/provider)

dump # (from /etc/ppp/peers/provider)

noauth # (from /etc/ppp/peers/provider)

remotename 3gppp # (from /etc/ppp/peers/provider)

/dev/ttyS0 # (from /etc/ppp/peers/provider)

115200 # (from /etc/ppp/peers/provider)

lock # (from /etc/ppp/peers/provider)

connect chat -s -v -f /etc/chatscripts/chat-connect -T hologram # (from /etc/ppp/peers/provider)

disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)

nocrtscts # (from /etc/ppp/peers/provider)

modem # (from /etc/ppp/peers/provider)

asyncmap 0 # (from /etc/ppp/options)

lcp-echo-failure 4 # (from /etc/ppp/options)

lcp-echo-interval 30 # (from /etc/ppp/options)

hide-password # (from /etc/ppp/peers/provider)

novj # (from /etc/ppp/peers/provider)

novjccomp # (from /etc/ppp/peers/provider)

ipcp-accept-local # (from /etc/ppp/peers/provider)

ipcp-accept-remote # (from /etc/ppp/peers/provider)

ipparam 3gppp # (from /etc/ppp/peers/provider)

noipdefault # (from /etc/ppp/peers/provider)

ipcp-max-failure 30 # (from /etc/ppp/peers/provider)

defaultroute # (from /etc/ppp/peers/provider)

usepeerdns # (from /etc/ppp/peers/provider)

noccp # (from /etc/ppp/peers/provider)

noipx # (from /etc/ppp/options)

abort on (BUSY)

abort on (NO CARRIER)

abort on (NO DIALTONE)

abort on (ERROR)

abort on (NO ANSWER)

timeout set to 30 seconds

send (AT^M)

expect (OK)



 -- got it

send (ATE0^M)

expect (OK)




 -- got it

send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)

expect (OK)





Revision: BG96MAR02A10M1G^M


SubEdition: V04^M


+CSQ: 99,99^M


+COPS: 0^M


+CGREG: 0,4^M



 -- got it

send (AT+CGDCONT=1,"IP","hologram",,0,0^M)

expect (OK)




 -- got it

send (ATD*99#^M)

expect (CONNECT)




 -- got it

Script chat -s -v -f /etc/chatscripts/chat-connect -T hologram finished (pid 4220), status = 0x0

Serial connection established.

using channel 15

Using interface ppp0

Connect: ppp0 <--> /dev/ttyS0

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x71deea05> <pcomp> <accomp>]

rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap MD5> <magic 0xd0c3350c> <pcomp> <accomp>]

No auth is possible

sent [LCP ConfRej id=0x0 <auth chap MD5>]

rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x71deea05> <pcomp> <accomp>]

rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd0c3350c> <pcomp> <accomp>]

sent [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xd0c3350c> <pcomp> <accomp>]

sent [LCP EchoReq id=0x0 magic=0x71deea05]

sent [IPCP ConfReq id=0x1 <addr> <ms-dns1> <ms-dns2>]

rcvd [LCP DiscReq id=0x2 magic=0xd0c3350c]

rcvd [LCP EchoRep id=0x0 magic=0xd0c3350c 71 de ea 05]

rcvd [IPCP ConfNak id=0x1 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x2 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x2 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x3 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x3 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x4 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x4 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x5 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x5 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x6 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x6 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x7 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x7 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x8 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x8 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x9 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x9 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xa <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xa <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xb <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xb <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xc <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xc <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xd <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xd <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xe <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xe <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0xf <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0xf <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x10 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x10 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x11 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x11 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x12 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x12 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x13 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x13 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x14 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x14 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x15 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x15 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x16 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x16 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x17 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x17 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x18 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x18 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x19 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x19 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1a <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x1a <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1b <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x1b <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1c <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x1c <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1d <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x1d <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1e <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [LCP EchoReq id=0x1 magic=0x71deea05]

rcvd [LCP EchoRep id=0x1 magic=0xd0c3350c 71 de ea 05]

rcvd [IPCP ConfNak id=0x1e <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x1f <addr> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x1f <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x20 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x20 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x21 <addr> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x21 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x22 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x22 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x23 <addr> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x23 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x24 <addr> <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

rcvd [IPCP ConfNak id=0x24 <ms-dns1> <ms-dns2> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [LCP EchoReq id=0x2 magic=0x71deea05]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

sent [IPCP ConfReq id=0x25 <addr> <ms-wins> <ms-wins>]

IPCP: timeout sending Config-Requests

sent [LCP TermReq id=0x2 "No network protocols running"]

sent [LCP TermReq id=0x3 "No network protocols running"]

Connection terminated.

abort on (ERROR)

abort on (NO DIALTONE)

Sending break to the modem

send (+++^M)

send (+++^M)

send (+++^M)


Script chat -s -v -f /etc/chatscripts/chat-disconnect finished (pid 4307), status = 0x0

Serial link disconnected.

Modem hangup

^CTerminating on signal 2

**pi@dronepi** : **~ $** ^C

Also I have to interrupt the cycle with control C if not it becomes a loop and keeps going and going as I get the same result

@humbertoromero49 This is exactly the same error I got. Do you figure it out? I used AT&T carrier.