Cellular IoT Sheid -BG96 Main Uart not working


I’m trying to use the main uart of the BG-96 mode with the sixfab celular Iot shield. The USB at cmd port is working fine, however the “main uart” isn’t responding to the “at” commands.

Please advise how to troubleshoot this further. I’m following the pinouts mentioned in the website.

I’m using version 1.1.0 of the cellular IoT HAT shield.

Make sure the serial port is enabled.
You can enable/disable the serial console with raspi-config:

  1. Start raspi-config: sudo raspi-config .
  2. Select option 5 - interfacing options.
  3. Select option P6 - serial.
  4. At the prompt Would you like a login shell to be accessible over serial? answer ‘No’
  5. At the prompt Would you like the serial port hardware to be enabled? answer ‘Yes’
  6. Exit raspi-config and reboot the Pi for changes to take effect.

UART configuration - Raspberry Pi Documentation

I would like to directly connect the BG-96 uart to the PC, using an external TTL to USB adaptor (3.3 V). But the main uart doesn’t respond

Could you provide me the details about the connection?