Can't register on network

Hi, as some others I can’t get the device online despite following the instructions. I increased the timeout to 120 in…

step_check_network = Step(
          retry=120,  # 120 times = 10 minute

but I always just get

DEBUG: check_network_registration : {'response': ['+CREG: 0,2', 'OK'], 'status': 1}
DEBUG: Response: ['\r\n+CREG: 0,2\r\n\r\nOK\r\n']
DEBUG: Processed: ['+CREG: 0,2', 'OK']
DEBUG: Fault: +CREG: 0,2

Tried some AT commands

ATI: {'response': ['Quectel', 'BG95-M3', 'Revision: BG95M3LAR02A03', 'OK'], 'status': 0}
AT+CSQ: {'response': ['+CSQ: 99,99', 'OK'], 'status': 0}
AT+QCSQ: {'response': ['+QCSQ: "NOSERVICE"', 'OK'], 'status': 0}

Not sure what to do here. Using the device for the first time, SIM is active, balance should be fine. Do I manually have to select band/provider? Thanks!


Make sure that the module is within an area with sufficient cellular network coverage for the selected network. Verify if other devices in the same location can establish a network connection. Then follow the instructions below and set the modem mode to GSM network priority and try.

Hi, so I tried GSM network priority but no difference. I even went outside (blue sky, good weather) with two phones next to me (T-Mobile and Vodafone), both had good LTE connectivity.

I don’t know how to select any (other) network, the only thing I see in Sixfab dashboard preferences is the APN called “super” but I can’t change that.

So not sure what to do here. My assumption would be that the defined LTE frequency bands are not matching with the region I’m in but thats a rather wild guess and I am no expert in the field.

Update - so I got this “fixed” by nuking the flash file as described here:

After that and reinstalling things connectivity worked right away.