Cannot send qmicli commands after installing libqmi-utils udhcpc

Hi I am trying to connect to the internet with my Twillio Super SIM to my Quectel UC20-G which is on a SixFab Base Hat. It seems to be going successfully but after installing

sudo apt update && sudo apt install libqmi-utils udhcpc

I run into an issue running the following command

sudo qmicli -d /dev/cdc-wdm0 --dms-set-operating-mode='online'
Which comes back with the following error:
[02 Dec 2021, 16:40:48] -Warning ** Error reading from istream: Resource temporarily unavailable
error: couldn't create client for the 'dms' service: CID allocation failed in the CTL client: Transaction timed out

I tried just “get-operation-mode” but same response

I ran
uname -r

5.10.63-v7+

lsusb -t

/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 1: Dev 3, If 0, Class=Hub, Driver=hub/3p, 480M
            |__ Port 2: Dev 5, If 3, Class=Vendor Specific Class, Driver=option, 480M
            |__ Port 2: Dev 5, If 1, Class=Vendor Specific Class, Driver=option, 480M
            |__ Port 2: Dev 5, If 4, Class=Vendor Specific Class, Driver=qmi_wwan, 480M
            |__ Port 2: Dev 5, If 2, Class=Vendor Specific Class, Driver=option, 480M
            |__ Port 2: Dev 5, If 0, Class=Vendor Specific Class, Driver=option, 480M
            |__ Port 1: Dev 7, If 0, Class=Vendor Specific Class, Driver=lan78xx, 480M
        |__ Port 2: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 6, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 6, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M

Any help would be appreciated!

Hi @simondpalmer ,

When you run the qmicli command, are you completely sure there are no other qmicli commands still running or ModemManager not running at the same time?

I ended up just purchasing the EC25-G with a twilio Super SIM following your tutorial and I’m up and running now. I’ll try and use this UC20 on a future application. Thanks!

This is not a solution. I’m running the same problem using libqmi-utils and not able to set operating mode.
If there are other commands still running, how can I detect them and how to stop them?

In BookWorm version in Raspberry Pi, it can be solved removing modemManager with the next commands:

systemctl disable ModemManager.service
systemctl stop ModemManager.service

Reboot RPi and try again… It will probably works…

Anyway, i strongly recommend to user modemManager. Is very easy to configure.

Follow this steps:

Check if modem is present

mmcli --list-modems

You must see:
/org/freedesktop/ModemManager1/Modem/0 [Telit] LE910C4-EU

Check modem capabilities

mmcli --modem=0

Add modem profile

nmcli connection add type gsm ifname ‘*’ con-name ‘NAME’ apn ‘APN_NAME’ connection.autoconnect yes gsm.pin 0000

Check profile creation and if it is linked

nmcli device status

You must see:
cdc-wdm0 gsm connected NAME

And if you run ifconfig, you must see your wwan0 interface connected and set up. Try ping to internet with this interface.

Regards

1 Like