Cannot connect to RPi over cellular ... only eth0/wlan0

Hi, Just started using the LTE hat. I have a Pi4 which I can connect to over eth0 and wlan0, but not wwan0.
I tried to “open terminal” from the sixfab dashboard and it works fine when eth0 and wlan0 are up, but if I take those “down”, it won’t connect over wwan0, which I expected.
I tried to change the priority of the interfaces from the dashboard, but that request to make the wwan0 the higher priority seems to be ignored and eth0 and or wlan0 are always higher priority than wwan0 in the dashboard.
Any thoughts on what to try next?

1 Like

Really not feeling the love here, guys.
If this is the best you can do for support, I’ll have to go find another way to get cellular on my IoTs …

1 Like

I noticed that the sixfab CORE device details page listed the firmware as “UNKNOWN”, so I thought I would update the firmware on the modem following these instructions: Telit Firmware Upgrade Guide. I ran the upgrade exe from Windows and while it connected to the modem (something like “modem found on XXX 7” it struggled to get a status from the device. After many retries it did get a status and proceeded with the firmware update. The update failed at about 40%, which appears to have now bricked the device …

Can anyone from Sixfab please comment on how to proceed???
Support from Sixfab did reach out over email a couple of days back asking for some information, which I provided and access, which I provided, but they have gone dark for over 24hrs again now.

Very disappointed in Sixfab at this point.

Seems there is an issue with the Telit modem, and Sixfab is working with Telit on the issue, but doesn’t yet have a resolution. This from the Sixfab support email today:

“The issue is regarding the ME910 bug that has been recently found. We are now working with the module OEM Telit to resolve this issue. Once solved we will reach out.”

Are you trying to make your HAT a mobile wifi hotspot?

I have the pi connected to a pixhawk4 and I’m running mavproxy on the pi to route the mavlink data from the pixhawk to a ground control app running on another laptop on the network. The plan is to have the pi openvpn into the home network over cellular to connect to the ground station laptop.

Are you planning to use RaspAp for OpenVPN?

1 Like

I posted my write-up on how I got the RaspAP working for me. Maybe it will help you.

1 Like

I just installed openvpn from the web site. Also, I just received a new lte hat, so once I install it, I’ll try out the openvpn installation. I’ll reach out if the installation doesn’t work, thanks!