Cannot communicate with EC25A over serial

I have a SixFab 3G/4G Raspberry pi hat and an EC25A modem. I have tried every way possible to change the APN stored in the modem. Of course, to do that, I need to send commands to that modem.

It should be noted that the SixFab hat / EC25 DOES work when I use a particular carrier (which does not require an APN).

I have tried the following:

#1. Removing the hat from the Raspberry and connecting a USB <-> Serial device to the TxD and RxD pins on the hat (6, 8 10). 115Kbaud, N,8,1, no handshaking, and powering the hat through the USB port. RESULT: No response when I type "ATZ .

#2. Putting the hat back on the Raspberry pi and loading Minicom, then setting Minicom to 115K N,8,1 no handshaking. I then connected my USB <-> Serial device RxD pin to first pin 8, then pin 10. to monitor the data flow. RESULT: The port displays typed chars when connected to pin 8, but nothing when connected pin 10.

#3. Loaded SER2NET so that chars sent over the net appear on the Pi’s serial port. I sent chars to the PI’s serial port and watched for response. I also monitored data on pin 8 using the USB <-> Serial converter. RESULT: Chars fed over the net appear on pin 8 of the Raspberry, but the EC25 does not respond.

What could I be doing wrong?


To change the APN, it seems you are using the USB - TTL converter. Did you try the USB cable that came with the HAT?

Let’s continue with the try#2 in your list.
Which device port did you try for the communication?
Please share an image of your setup.

What are the outputs of the following Linux commands?
ls /dev/ttyUSB*

I believe there is some confusion.

All you need to do is:

  1. Connect the USB cable between the HAT and the Raspberry Pi.
  2. Open minicom with ttyUSB2(default baudrate is 115200)
    minicom -D /dev/ttyUSB2
  3. Issue the AT commands to the module.

That was it! I thought the modem used the Raspberry pi’s hardware serial port for control.

Thank you!