Booting to an earlier version of Raspberry Pi OS

Hi All,

I have been having problems with my Sixfab modem since I upgraded the Raspberry Pi OS a few days ago. The device always says “offline” now, and I am not able to get into it using the Remote Terminal from the web. I can ssh into it locally from my phone when on its Wifi network, but the internet connection is extremely spotty. Sometimes I will get a response from pinging, to test its cellular connection to the net, and most times will not get a response. AT+csq, which normally tells me the cell signal strength, says it doesn’t know what port to check. I am not able to successfully run the command sudo apt update because the internet connection fails during download from the server. Rebooting does not solve the issue. The Sixfab firmware is already up to date.

I have a previous copy of a working OS from this device from August 2022 that I could flash to the micro SD card, and plug back in. From Sixfab’s end, are there any potential problems with going back to a working saved state from the past?

Reporting back. Swapping the SD card for one flashed with an earlier OS state solved the problem. The firmware needed to be updated on the Sixfab Connect webpage to match the older OS version, and then the Pi needed a reboot. After that, the Pi has been consistently online.

Another follow-up. My cellular service still appears to be down 16% of the time, or possibly more, based on daily reports on Sixfab Connect. I have tracked this issue down, and found that the Raspberry Pi is experiencing low voltage faults, causing it to throttle itself, which cuts out the modem functionality. (It was not throttling itself because it was too hot, which was my other hypothesis.)

The way to see if either of these situations is happening is by using the vcgencmd command in Remote Terminal, during a period when the cellular connection is up.

sudo vcgencmd measure_temp (gives you the cpu temp in degrees C)

sudo vcgencmd get_throttled (lets you know if the Pi had to throttle itself recently, and if so, the reason)

man vcgencmd (gives you the manual for this command, so you know what the throttled values mean)

In my case the culprit was low voltage. I have a 12 volt to 5 volt buck converter supplying the Pi with up to 3 amps of juice. It has worked fine up until recently, and I suspect it may be nearing the end of its service life. I’m going to replace it with a beefier unit so that the Pi can draw more amps when needed, and the converter won’t be running near its maximum output all the time.

Hopefully this helps someone else who is having intermittent connection issues.

1 Like