Bad antenna or something else

OK, so I’ve got a 4g hat with at&t sim in it - ordered just for this hat, so they associated the imei with it.

  1. I cannot get ppp or qmi to connect.

  2. I CAN send SMS messages to and from the PI, so I know that the sim is activated.

  3. My signal looks ok except for RSRP:

    pi@mixerpi:~ $ sudo qmicli -d /dev/cdc-wdm0 --nas-get-signal-strength
    [/dev/cdc-wdm0] Successfully got signal strength
    Network ‘lte’: ‘-73 dBm’
    Network ‘lte’: ‘-73 dBm’
    Network ‘lte’: ‘-2.5 dBm’
    IO: ‘-106 dBm’
    SINR (8): ‘9.0 dB’
    Network ‘lte’: ‘-11 dB’
    Network ‘lte’: ‘1.8 dB’
    Network ‘lte’: ‘-108 dBm’
    pi@mixerpi:~ $

I’ve tried varios APNs, but I’ve found notes about this:
+CSQ: 19,99^M
Being resolved by replacing the antenna.

I’m using the pair of antennas that come in the sixfab kit.
I’m testing with a raspbery pi 3 B+…

1 Like

This appears to be an AT&T provisioning issue.
I got to poking around around and found that they stuck the device under a NEW plan, with NO data. The usage tracker shows my test SMSs. No data at all explains the ‘no auth’ messages when I tried using PPP.

Yay more time on hold. Woo.

Hi @willo,

Please share the whole log of sudo pon or sudo ./quectel-CM -s < APN >.

Did you try with different sim too?

Old thread but I’d forgotten to share.
In the end, activation worked when we used a different device, and then sim swapped.
Since then it’s worked pretty well, with some interesting quirks now and then.

Great example - yesterday down in the florida keys, internet was being very, very slow. Via my phone as a hotspot on the same carrier, no problem. I finally just powered the pi down for the evening.
This morning, I powered it up and it worked great!

I’m suspecting that roaming across the US caused it to get kinda goofy - maybe a stuck ip tunnel or something, dunno.

1 Like