After installing /etc/peers directory remains to be empty

I’ve followed the procedure of: # Setting up the PPP connection for Sixfab Shield/HAT
Everything seems ok till I had to run the command to connect the Internet sudo pon

please refer to the picture:
above the procedure I followed
bottom the command box I ran
right hand the directory listing


Hi @gerie.alards,

First of all, you should set up the hardware properly. Please check out getting started.

If you encounter any problems, please follow the troubleshooting procedures:

if you had read my remarks more carefully you would have noticed that i did install everything accordingly to the getting started and troubleshooting procedures over the last days again and again.
But if you are not willing take my problem more seriously I will send the hardware back asap.

How did you set up PPP? Could you please explain the steps in detail?

it already goes wrong before I’m able to set the PPP

Raspberry PI 4 Model B Rev 1.2
Debian version 10.6

Raspberry Pi Cellular IoT Application Shield – LTE-M & NB-IoT & eGPRS
LTE – GNSS Dual u.FL Antenna
40 pin Header
Right Angle Micro USB Cable

I tried both sim cards with an older debian version (june 2020 but never got it right)
Simyo simcard
worldmobile IoT/M2M Internal SIM

  1. Insert the SIM card to the shield.

  2. Attach the antenna, Make sure you are using the right antenna port. LTE goes to LTE port and GPS to the GNSS port.

  3. Attach the shield to the Raspberry Pi.

  4. Finally, connect the USB cable to the shield and Raspberry Pi.

  5. Start raspi-config: sudo raspi-config.

  6. Select option 5 - interfacing options.

  7. Select option P6 - serial. >>>> THIS IS OPTION 3 IN NEWER RELEASES <<<<

  8. At the prompt Would you like a login shell to be accessible over serial? answer ‘No’.

  9. At the prompt Would you like the serial port hardware to be enabled? answer ‘Yes’.

  10. Exit raspi-config and reboot the Pi for changes to take effect.

ls /dev/ttyUSB*

no file or directory

  1. sudo apt update
  2. sudo rpi-update a995f0c9a9b3e5dbd2a41f69f5c4c82cdf33c7ec

your firmware was succesfully updated to a995f0c9a9b3e5dbd2a41f69f5c4c82cdf33c7ec

  1. sudo reboot

Library installation

  1. git clone GitHub - sixfab/Sixfab_RPi_CellularIoT_App_Shield: Python Library for Sixfab RPi Cellular IoT and Sixfab RPi Cellular IoT Application Shields
    … done

  2. cd Sixfab_RPi_CellularIoT_Library

  3. sudo python3 install

BUT ls /dev/ttyUSB*
no files !!!

Make sure your module is powered up. It can be turned on by pushing the PWRKEY button for at least 500ms. Also, could you share a picture of your hardware setup?

finally the ‘pon’ is recognized now however I ran into the following:

pi@raspberrypi:~ $ sudo pon
/usr/sbin/pppd: The remote system (3gppp) is required to authenticate itself
/usr/sbin/pppd: but I couldn’t find any suitable secret (password) for it to use to do so.

settings as follow:

I2C enabled YES
login shell to be accessible over serial? NO
serial port hardware to be enabled? YES

I have a Simyo sim card installed.

What is your carrier APN?
Does your carrier need username and password? [Y/n]
Enter username
Enter password
What is your device communication PORT? (ttyS0/ttyUSB3/etc.)
Do you want to activate auto connect/reconnect service at R.Pi boot up? [Y/n]
To connect to internet run “sudo pon” and to disconnect run “sudo poff”
Press ENTER key to reboot

I got a Raspberry 3b now instead of 4B

see picturesimage1

Please, confirm the APN from the ISP. The APN could be different from the one used in mobile phones.

sorry don’t understand this >> confirm the APN from the ISP. <<

I mean, contact the SIM card supplier(Simyo) to confirm the APN.

I replaced the Simyo sim card for World Mobile International SIMsim but still get this after: sudo pon
pi@raspberrypi:~ $ sudo pon
/usr/sbin/pppd: The remote system (3gppp) is required to authenticate itself
/usr/sbin/pppd: but I couldn’t find any suitable secret (password) for it to use to do so.
pi@raspberrypi:~ $

After replacing the SIM did you change the APN and Authentication credentials from the /etc/ppp/peers/provider?

What is the APN of the World Mobile International SIM? Does it need any credentials? If yes what is the authentication type? (PAP/CHAP) You can find this information from the SIM Vendor.