4G HAT question

I just recently purchased a 4G HAT (and a 4G modem: EC25-A) for my Raspberry Pi 4 (running Raspberry Pi OS). Assembled it, and was able to install the drivers no problem. I then activated the included Twilio SIM and then I ran into my problems. I tried connecting my HAT as per the QMI installation instructions, but when I went to connect I could not gain a lease. After days of searching both these forums and Raspberry Pi’s forums I concluded that dchcpd and udchpc weren’t agreeing with each other. I stopped dchcpd service and all of a sudden my EC25 is connecting to the cellular network. However, in doing so I am (seemingly??) unable to monitor/control the Pi’s wired and wireless connections.

Now my question is: Did I miss something? Nowhere in the installation instructions mentions the disabling/stopping of dchcpd service. Am I not able to have this service running? Is there a way where I can control all networking interfaces that isn’t through command line/terminal?

Thanks in advance!
Bravo Ki

1 Like