3/4G/LTE base hat with IoT LoRa Gateway


I have installed the 3/4G/LTE base hat on a raspberry with a very long header
My object is to add over the base hat this LoRaWANN gayteway

I can make it working on a Raspverry Pi3 as I can make working the Base Hat.

But I wonder if I add both on the same raspberry, the base Hat and the gateway will works together by installing the corresponding dsoftware

Any experience to share?
Many thank


We have not tested it.

Since there is no conflicting pin between the Base HAT and the LoRa HAT, you may use it.

It seams to be working. I just wrote an article here (in french, sorry. I will look to translate it later).
Until now, my LoRaWAN gateway is connected to TTN.

1 Like


Thank you for sharing

Dear Saeed,

In fact, it’s look like it’s not completely finished :grinning:.
Yestreday, TTN console showed me a green light regarding the connection, but it may be possible that the green ligth remind green some time even if the connection is lost. This morning my gateway was not connected anymore to TTN even if

ifconfig wwan0

show me a successfull connection

wwan0: flags=4291<UP,BROADCAST,RUNNING,NOARP,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::b5ff:b507:9b4:701a prefixlen 64 scopeid 0x20
ether 0f:ef:01:f7:13:f5 txqueuelen 1000 (Ethernet)
RX packets 6 bytes 1400 (1.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 48 bytes 8867 (8.6 KiB)
TX errors 0 dropped 10 overruns 0 carrier 0 collisions 0

(I changed the IP)

For me, all installation went fine. Before adding the Bas HAT, my gateway could be connected while it was connected to my home WiFi. Now I disconnected from my Home WiFi, as I added the Bas HAT and even if ifconfig showed me a 4G connection, my gateway can not be connected.

I wonder if I missed a step. I thougt the step I did, was enough to connect my Gateway to the network becaue of Base HAT, which return me a successfully 4G connection.

Data could be sent from my Base HAT, isn’t?

However, I wonder if I should install RaspAP and create an Hotspot name “newhotspot”, and then modify the /etc/wpa_supplicant/wpa_supplicant.conf and configure the Wireless to access the hotspot provided by himself.


Do you understand what I am saying :grinning: ?

It a bit funny, because usually we connect a devise to a WiFI routeur, but in that case we connect it to himself

NB: from my Raspberry, I can ping

ping www.google.ch

So the connection is good

What’s your point of view?

I did some other test. It looke like the IoT LoRa Gateway send the data only from WLAN. When I clear the WLAN configuration, the data can not be sent to WWAN, even if I can ping a external web site from WWAN.

Is there a way to forward all package from WLAN to WANN?

I run route -n and here is the result

route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         10.164.xx.200         UG    0      0        0 wwan0         UG    202    0        0 eth0
10.164.xx.192 U     0      0        0 wwan0     U     0      0        0 wwan0   U     202    0        0 eth0

Any idea why there is this line with an IP starting with 169.254 U 0 0 0 wwan0


ip route
default via dev eth0 proto dhcp src metric 202 dev wwan0 scope link src dev eth0 proto dhcp scope link src metric 202 

Why wwan show me
why when I run ifconfig wwan0, inet show me

inet 10.164.xx.xx netmask broadcast 10.164.xx.x07

It’s look like my gateway does not want to communicate with wwan0