from NAT?

[Using Raspberry Pi Cellular IoT Kit w/ Telit ME910C1].

wwan0 gets IP address Is this setup doing NAT? I expected a route-able IP address, not a NAT address, like in this example with ECM on Telit LE910C1 (wwan0 gets

How do I get an IP addr like in the example above? I don’t want a NAT addr.

Any help here?

I looking for to get the route-able public IP address of the cellular modem’s wwan0, not this local non-routeable address.

Any help? This Telit ME910C1 modem is not giving me a route-able IP address. Can I exchange the Telit ME910C1 for a Telit LE910C1 or LE910C4?


With the ECM mode, the module doesn’t give any access to route the IP address.
The ECM mode details can be found in section 3.24 of the AT command Manual of ME910.

If you are looking for non local IP, you can test PPP instead of ECM.

ECM gives similar address for all the modules.

I had already found that section on ECM and it doesn’t say anything about local vs. non-local IP address. It just describes how to enable ECM mode. Why is ECM mode behaving differently from the LE910* models? My understanding is ECM mode on LE910* will give a non-local IP address to wwan0.

I just tried PPP mode instead of ECM and it’s a no-go. Following the instructions, I did:

  1. AT#USBCFG=0

  2. sudo ./ppp_install_standalone.sh

    selected: 3G, 4G/LTE Base Shield
    APN: super
    username/password: no
    port: ttyUSB3
    active on boot: yes

After reboot, wwan0 has IP Does not ping to sixfab.com.

Tried running sudo pon:

pi@raspberrypi:~ $ sudo pon
/usr/sbin/pppd: In file /etc/ppp/peers/provider: unrecognized option '/dev/ttyUSB3'

pi@raspberrypi:~ $ ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1  /dev/ttyUSB2

Later, wwan0 reverts to

Hey @sfeldma, from your last message, your sudo pon command returned that /dev/ttyUSB3 is not being recognized…

Your ls /dev/ttyUSB* is returning /dev/ttyUSB0, /dev/ttyUSB1 or /dev/ttyUSB2 so there’s only those options that that you can apply in your specific case.

To make sure you’re using the correct one, I’d recommend sending AT command which should return OK if the connection with the module is correctly established.

To be clearer:

  • Follow the Sending AT Commands guide and send the command AT to any of the 3 /dev/ttyUSB ports and if you see OK being returned then you can use that port for your comfguration.

Hope this helps! FYI, I’m not part of the Sixfab team, just a customer also struggling to get my HAT working with my module and only sharing what I’ve learned during that experience :smile:

I got PPP connection working with a non-local IP address using an LE910C4 modem. I was never able to get this to work with the ME910C1. I used the “Standalone installation” instructions.

pi@raspberrypi:~ $ ip a show ppp0
6: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 3
    inet peer scope global ppp0
       valid_lft forever preferred_lft forever

pi@raspberrypi:~ $ ping -c 2 -I ppp0 sixfab.com
PING sixfab.com ( from ppp0: 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=52 time=151 ms
64 bytes from ( icmp_seq=2 ttl=52 time=230 ms

--- sixfab.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 2ms
rtt min/avg/max/mdev = 151.008/190.703/230.398/39.695 ms

Now that I have LE910C4 working with PPP and giving me a non-local IP address, I tried replacing the LE910C4 with ME910C1 and re-ran sudo ./ppp_install_standalone.sh. This time I specified ttyUSB2. The script ran without error and I rebooted the Pi. ppp0 was there with a non-local IP address, but ping thru ppp0 does not work.

So something isn’t right with the PPP instructions/scripts for ME910C1.