RPi 4 4GB, Power Management & UPS HAT, Official RPi 7" LCD Screen, no screen power up, image

LCD is powered from its own supply. The LCD screen does not power on when system power is connected through the UPS HAT. Battery charge led is green in this case and the system boots up and powers USB devices. The LCD back light does not appear to be on. When the pi is connected directly using the same (official RPi) USB-C, the LCD works as expected.

Note: I have not installed the soft shutdown pin. Open to that being the issue but I have my doubts.

System is as described in the title, but also has the sixfab 3/4G-LTE cellular HAT, and BerryGPS IMUv3. The cellular HAT remains untested for the moment, but the GPS HAT works fine (and is the top-most).

I would like to use the battery only to allow soft shutdown when the power source is removed. I do not need to keep it powered but do want it to automatically power the pi when power is re-applied (which I think is already the case).

What would be a place to start with further troubleshooting?
Are there settings somewhere that I missed? Configuration?


I have the RPi3B. I power my 7" touch screen through the pins on the UPS HAT. I connect the power adapter to the UPS HAT and it charges the battery and I can disconnect the adapter and the entire unit, including LCD functions on battery power. My RPi does not require the supplied POGO pin nor is there a contact point on my Pi for such pin. I don’t know, support seems hard to come by on this forum unless you talk the talk… obviously I do not.

Finally got around to playing with this again…

I have installed the POGO pin and soldered the 5V manually. This solves the screen on problem, but makes another problem quite apparent.

How does one get the Rpi to turn on immediately upon being plugged into external power. “Safe shutdown” using the battery level is not an acceptable solution to me. I want to the soft shutdown to begin as soon as external power is removed (I solved this, for the most part).

Start up seems to be a problem. When I mount the Rpi, I will not have access to the buttons.

Solved this problem with some external hardware.